Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame] | 1 | require gcc-configure-xilinx-standalone.inc |
| 2 | |
| 3 | COMPATIBLE_HOST = "${HOST_SYS}" |
| 4 | |
| 5 | python do_multilib_install_xilinx-standalone_class-target () { |
| 6 | pass |
| 7 | } |
| 8 | |
| 9 | standalone_fixup () { |
| 10 | ( |
| 11 | cd ${D}${libdir} |
| 12 | for each in ${TARGET_SYS}/*/* ; do |
| 13 | ln -s $each $(basename $each) |
| 14 | done |
| 15 | ) |
| 16 | } |
| 17 | |
| 18 | FIXUP_FUNCTION = "" |
| 19 | FIXUP_FUNCTION_xilinx-standalone_class-target = " standalone_fixup" |
| 20 | |
| 21 | do_install[postfuncs] .= "${FIXUP_FUNCTION}" |
| 22 | |
| 23 | FILES_${PN}-dev_append_xilinx-standalone_class-target = " \ |
| 24 | ${libdir}/*.a \ |
| 25 | ${libdir}/*.o \ |
| 26 | " |