Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Trace and analyze execution of a program written in C/C++" |
| 2 | HOMEPAGE = "https://github.com/namhyung/uftrace" |
| 3 | BUGTRACKER = "https://github.com/namhyung/uftrace/issues" |
| 4 | SECTION = "devel" |
| 5 | LICENSE = "GPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 7 | |
| 8 | DEPENDS = "elfutils" |
| 9 | DEPENDS:append:libc-musl = " argp-standalone" |
| 10 | |
| 11 | inherit autotools |
| 12 | |
| 13 | SRCREV = "304a492652dc0fd220f601167c4ebb30e2ae4a39" |
| 14 | SRC_URI = "git://github.com/namhyung/${BPN};branch=master;protocol=https \ |
| 15 | " |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | LDFLAGS:append:libc-musl = " -largp" |
| 19 | |
| 20 | def set_target_arch(d): |
| 21 | import re |
| 22 | arch = d.getVar('TARGET_ARCH') |
| 23 | if re.match(r'i.86', arch, re.I): |
| 24 | return 'i386' |
| 25 | elif re.match('armeb', arch, re.I): |
| 26 | return 'arm' |
| 27 | else: |
| 28 | return arch |
| 29 | |
| 30 | EXTRA_UFTRACE_OECONF = "ARCH=${@set_target_arch(d)} \ |
| 31 | with_elfutils=/use/libelf/from/sysroot" |
| 32 | |
| 33 | do_configure() { |
| 34 | ${S}/configure ${EXTRA_UFTRACE_OECONF} |
| 35 | } |
| 36 | |
| 37 | FILES_SOLIBSDEV = "" |
| 38 | FILES:${PN} += "${libdir}/*.so" |
| 39 | |
| 40 | COMPATIBLE_HOST = "(i.86|x86_64|aarch64|arm)" |
| 41 | |
| 42 | # uftrace supports armv6 and above |
| 43 | COMPATIBLE_HOST:armv4 = 'null' |
| 44 | COMPATIBLE_HOST:armv5 = 'null' |