Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "A filesystem snapshot utility based on rsync" |
| 2 | HOMEPAGE = "http://www.rsnapshot.org" |
| 3 | BUGTRACKER = "https://sourceforge.net/projects/rsnapshot/" |
| 4 | SECTION = "console/network" |
| 5 | |
| 6 | LICENSE = "GPLv2" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=892f569a555ba9c07a568a7c0c4fa63a" |
| 8 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 9 | RDEPENDS:${PN} = "rsync \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 10 | perl \ |
| 11 | perl-module-dirhandle \ |
| 12 | perl-module-cwd \ |
| 13 | perl-module-getopt-std \ |
| 14 | perl-module-file-path \ |
| 15 | perl-module-file-stat \ |
Andrew Geissler | bbbd5f4 | 2020-10-30 15:42:48 -0500 | [diff] [blame] | 16 | perl-module-file-spec \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 17 | perl-module-posix \ |
| 18 | perl-module-fcntl \ |
| 19 | perl-module-io-file \ |
| 20 | perl-module-constant \ |
| 21 | perl-module-overloading \ |
Andrew Geissler | bbbd5f4 | 2020-10-30 15:42:48 -0500 | [diff] [blame] | 22 | perl-module-ipc-open3 \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 23 | " |
| 24 | |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 25 | SRCREV = "4dc82bfe6be3f83fcfa94946dcf6accfd6a18031" |
| 26 | PV = "1.4.4+git${SRCPV}" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 27 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 28 | SRC_URI = "git://github.com/DrHyde/${BPN};branch=master;protocol=https \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 29 | file://configure-fix-cmd_rsync.patch \ |
| 30 | " |
| 31 | |
| 32 | S = "${WORKDIR}/git" |
| 33 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 34 | inherit autotools perlnative |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 35 | |
| 36 | # Fix rsnapshot.conf.default: |
| 37 | # don't inject the host path into target configs. |
| 38 | EXTRA_OECONF += "--without-cp \ |
| 39 | --without-rm \ |
| 40 | --without-du \ |
| 41 | --without-ssh \ |
| 42 | --without-logger \ |
| 43 | --without-rsync \ |
| 44 | ac_cv_path_PERL=${bindir}/perl \ |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 45 | ac_cv_path_MOUNT=${base_bindir}/mount \ |
| 46 | ac_cv_path_UMOUNT=${base_bindir}/umount \ |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 47 | " |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 48 | |
| 49 | # Create 't/include.ac' before starting the autoreconf to fix configure |
| 50 | # error: configure.ac:302: file 't/include.ac' does not exist |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 51 | do_configure:prepend(){ |
Patrick Williams | ddad1a1 | 2017-02-23 20:36:32 -0600 | [diff] [blame] | 52 | saved_dir=`pwd` |
| 53 | cd ${S}; ./autogen.sh |
| 54 | cd ${saved_dir} |
| 55 | } |