Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame^] | 1 | SUMMARY = "CircuitPython bus device classes to manage bus sharing." |
| 2 | HOMEPAGE = "https://github.com/adafruit/Adafruit_CircuitPython_BusDevice" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=6ec69d6e9e6c85adfb7799d7f8cf044e" |
| 5 | |
| 6 | SRC_URI = "git://github.com/adafruit/Adafruit_CircuitPython_BusDevice.git;branch=main;protocol=https" |
| 7 | SRCREV = "1bfe8005293205e2f7b2cc498ab5a946f1133b40" |
| 8 | |
| 9 | S = "${WORKDIR}/git" |
| 10 | |
| 11 | inherit setuptools3 |
| 12 | |
| 13 | DEPENDS += "python3-setuptools-scm-native" |
| 14 | |
| 15 | RDEPENDS:${PN} += " \ |
| 16 | python3-adafruit-blinka \ |
| 17 | python3-core \ |
| 18 | " |
| 19 | COMPATIBLE_HOST:libc-musl:class-target = "null" |