Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame^] | 1 | SUMMARY = "Python parsing module" |
| 2 | DESCRIPTION = "The pyparsing module is an alternative approach to creating \ |
| 3 | and executing simple grammars, vs. the traditional lex/yacc approach, or \ |
| 4 | the use of regular expressions. The pyparsing module provides a library of \ |
| 5 | classes that client code uses to construct the grammar directly in Python \ |
| 6 | code." |
| 7 | HOMEPAGE = "https://github.com/pyparsing/pyparsing/" |
| 8 | BUGTRACKER = "https://github.com/pyparsing/pyparsing/issues" |
| 9 | |
| 10 | LICENSE = "MIT" |
| 11 | LIC_FILES_CHKSUM = "file://LICENSE;md5=657a566233888513e1f07ba13e2f47f1" |
| 12 | |
| 13 | SRC_URI[sha256sum] = "18ee9022775d270c55187733956460083db60b37d0d0fb357445f3094eed3eea" |
| 14 | |
| 15 | UPSTREAM_CHECK_REGEX = "pyparsing-(?P<pver>.*)\.tar" |
| 16 | |
| 17 | inherit pypi setuptools3 |
| 18 | |
| 19 | RDEPENDS:${PN} += " \ |
| 20 | ${PYTHON_PN}-datetime \ |
| 21 | ${PYTHON_PN}-debugger \ |
| 22 | ${PYTHON_PN}-json \ |
| 23 | ${PYTHON_PN}-netclient \ |
| 24 | ${PYTHON_PN}-pprint \ |
| 25 | ${PYTHON_PN}-stringold \ |
| 26 | ${PYTHON_PN}-threading \ |
| 27 | " |
| 28 | |
| 29 | BBCLASSEXTEND = "native nativesdk" |