Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame^] | 1 | SUMMARY = "System load testing utility" |
| 2 | DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \ |
| 3 | imposes a configurable amount of CPU, memory, I/O, and disk stress on the system." |
| 4 | HOMEPAGE = "https://github.com/ColinIanKing/stress-ng#readme" |
| 5 | LICENSE = "GPL-2.0-only" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 7 | |
| 8 | SRC_URI = "git://github.com/ColinIanKing/stress-ng.git;protocol=https;branch=master" |
| 9 | SRCREV = "48be8ff4ffc4a04a0e3b5f2feaf63cce0cbd4f2b" |
| 10 | S = "${WORKDIR}/git" |
| 11 | |
| 12 | DEPENDS = "coreutils-native" |
| 13 | |
| 14 | PROVIDES = "stress" |
| 15 | RPROVIDES:${PN} = "stress" |
| 16 | RREPLACES:${PN} = "stress" |
| 17 | RCONFLICTS:${PN} = "stress" |
| 18 | |
| 19 | inherit bash-completion |
| 20 | |
| 21 | do_install() { |
| 22 | oe_runmake DESTDIR=${D} install |
| 23 | ln -s stress-ng ${D}${bindir}/stress |
| 24 | } |