Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 1 | SUMMARY = "A C library for selecting an OpenGL API and window system at runtime" |
| 2 | DESCRIPTION = "A cross-platform C library that allows one to defer selection \ |
| 3 | of an OpenGL API and window system until runtime. For example, on Linux, Waffle \ |
| 4 | enables an application to select X11/EGL with an OpenGL 3.3 core profile, \ |
| 5 | Wayland with OpenGL ES2, and other window system / API combinations." |
| 6 | HOMEPAGE = "https://gitlab.freedesktop.org/mesa/waffle" |
| 7 | BUGTRACKER = "https://gitlab.freedesktop.org/mesa/waffle" |
| 8 | LICENSE = "BSD-2-Clause" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4c5154407c2490750dd461c50ad94797 \ |
| 10 | file://include/waffle-1/waffle.h;endline=24;md5=61dbf8697f61c78645e75a93c585b1bf" |
| 11 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 12 | SRC_URI = "git://gitlab.freedesktop.org/mesa/waffle.git;protocol=https;branch=master \ |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 13 | file://0001-waffle-do-not-make-core-protocol-into-the-library.patch \ |
| 14 | " |
| 15 | SRCREV = "905c6c10f2483adf0cbfa024e2d3c2ed541fb300" |
| 16 | S = "${WORKDIR}/git" |
| 17 | |
| 18 | inherit meson features_check lib_package bash-completion pkgconfig |
| 19 | |
Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 20 | DEPENDS:append = " python3 cmake-native" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 21 | |
| 22 | # This should be overridden per-machine to reflect the capabilities of the GL |
| 23 | # stack. |
| 24 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'glx x11-egl', '', d)} \ |
| 25 | ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)} \ |
| 26 | surfaceless-egl gbm" |
| 27 | |
| 28 | # virtual/libgl requires opengl in DISTRO_FEATURES. |
| 29 | REQUIRED_DISTRO_FEATURES += "${@bb.utils.contains('DEPENDS', 'virtual/${MLPREFIX}libgl', 'opengl', '', d)}" |
| 30 | |
| 31 | # I say virtual/libgl, actually wants gl.pc |
| 32 | PACKAGECONFIG[glx] = "-Dglx=enabled,-Dglx=disabled,virtual/${MLPREFIX}libgl libx11" |
| 33 | |
| 34 | # I say virtual/libgl, actually wants wayland-egl.pc, egl.pc, and the wayland |
| 35 | # DISTRO_FEATURE. |
Andrew Geissler | 7e0e3c0 | 2022-02-25 20:34:39 +0000 | [diff] [blame^] | 36 | PACKAGECONFIG[wayland] = "-Dwayland=enabled,-Dwayland=disabled,virtual/${MLPREFIX}libgl wayland wayland-native wayland-protocols" |
Andrew Geissler | eff2747 | 2021-10-29 15:35:00 -0500 | [diff] [blame] | 37 | |
| 38 | # I say virtual/libgl, actually wants gbm.pc egl.pc |
| 39 | PACKAGECONFIG[gbm] = "-Dgbm=enabled,-Dgbm=disabled,virtual/${MLPREFIX}libgl udev" |
| 40 | |
| 41 | # I say virtual/libgl, actually wants egl.pc |
| 42 | PACKAGECONFIG[x11-egl] = "-Dx11_egl=enabled,-Dx11_egl=disabled,virtual/${MLPREFIX}libgl libxcb" |
| 43 | PACKAGECONFIG[surfaceless-egl] = "-Dsurfaceless_egl=enabled,-Dsurfaceless_egl=disabled,virtual/${MLPREFIX}libgl" |
| 44 | |
| 45 | # TODO: optionally build manpages and examples |
| 46 | |
| 47 | do_install:append() { |
| 48 | sed -i -e "s,${WORKDIR},,g" ${D}/${libdir}/cmake/Waffle/WaffleConfig.cmake |
| 49 | } |