Brad Bishop | 7e36d53 | 2019-09-16 07:44:26 -0400 | [diff] [blame^] | 1 | SUMMARY = "Display dialog boxes from the command line and shell scripts" |
| 2 | SECTION = "x11/gnome" |
| 3 | LICENSE = "GPLv2+" |
| 4 | |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7" |
| 6 | |
| 7 | inherit distro_features_check gnomebase gettext |
| 8 | |
| 9 | DEPENDS = "gtk+3" |
| 10 | |
| 11 | REQUIRED_DISTRO_FEATURES = "x11" |
| 12 | |
| 13 | SRC_URI = "${GNOME_MIRROR}/${GNOMEBN}/${@gnome_verdir("${PV}")}/${GNOMEBN}-${PV}.tar.${GNOME_COMPRESS_TYPE};name=archive \ |
| 14 | file://0001-build-don-t-generate-manual.patch \ |
| 15 | " |
| 16 | |
| 17 | SRC_URI[archive.md5sum] = "ba2b2a13248773b4ec0fd323d95e6d5a" |
| 18 | SRC_URI[archive.sha256sum] = "e786e733569c97372c3ef1776e71be7e7599ebe87e11e8ad67dcc2e63a82cd95" |
| 19 | GNOME_COMPRESS_TYPE="xz" |
| 20 | |
| 21 | do_install_append() { |
| 22 | # Remove gdialog compatibility helper - we don't want to pull in perl |
| 23 | rm ${D}${bindir}/gdialog |
| 24 | } |