Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "The module provides handy URL class for url parsing and changing" |
| 2 | HOMEPAGE = "https://github.com/aio-libs/yarl/" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b334fc90d45983db318f54fd5bf6c90b" |
| 5 | |
| 6 | SRC_URI[md5sum] = "08ba0d6e18f460b44d9e5459f3d217ba" |
| 7 | SRC_URI[sha256sum] = "58cd9c469eced558cd81aa3f484b2924e8897049e06889e8ff2510435b7ef74b" |
| 8 | |
| 9 | SRC_URI += " \ |
| 10 | file://run-ptest \ |
| 11 | " |
| 12 | |
| 13 | PYPI_PACKAGE = "yarl" |
| 14 | |
| 15 | inherit pypi ptest setuptools3 |
| 16 | |
| 17 | RDEPENDS_${PN} = "\ |
| 18 | ${PYTHON_PN}-multidict \ |
| 19 | ${PYTHON_PN}-idna \ |
| 20 | " |
| 21 | |
| 22 | RDEPENDS_${PN}-ptest += " \ |
| 23 | ${PYTHON_PN}-pytest \ |
| 24 | " |
| 25 | |
| 26 | do_install_ptest() { |
| 27 | install -d ${D}${PTEST_PATH}/tests |
| 28 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 29 | } |