Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Additional utilities for the opkg package manager" |
| 2 | SUMMARY_update-alternatives-opkg = "Utility for managing the alternatives system" |
| 3 | SECTION = "base" |
| 4 | HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils" |
| 5 | LICENSE = "GPLv2+" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ |
| 7 | file://opkg.py;beginline=2;endline=18;md5=63ce9e6bcc445181cd9e4baf4b4ccc35" |
| 8 | PROVIDES += "${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'virtual/update-alternatives', '', d)}" |
| 9 | |
| 10 | SRC_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/${BPN}/snapshot/${BPN}-${PV}.tar.gz \ |
| 11 | file://0001-Switch-all-scripts-to-use-Python-3.x.patch \ |
| 12 | file://0001-Only-use-sort-name-on-versions-of-tar-which-support-.patch \ |
| 13 | file://0002-opkg-build-Use-local-time-for-build_date-since-opkg-.patch \ |
| 14 | file://threaded-xz.patch \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 15 | file://pigz.patch \ |
Brad Bishop | a5c52ff | 2018-11-23 10:55:50 +1300 | [diff] [blame] | 16 | file://0001-update-alternatives-Fix-link-relocation-support.patch \ |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 17 | " |
| 18 | SRC_URI_append_class-native = " file://tar_ignore_error.patch" |
| 19 | UPSTREAM_CHECK_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils/refs/" |
| 20 | |
| 21 | |
| 22 | SRC_URI[md5sum] = "391c1c80aca26961375dd22e1d2d0cbf" |
| 23 | SRC_URI[sha256sum] = "26b3f4dd1c1ef65f519d4cddfb35ebea41ae8af989aea2699a39783598c33769" |
| 24 | |
| 25 | TARGET_CC_ARCH += "${LDFLAGS}" |
| 26 | |
| 27 | # For native builds we use the host Python |
| 28 | PYTHONRDEPS = "python3 python3-shell python3-io python3-math python3-crypt python3-logging python3-fcntl python3-pickle python3-compression python3-stringold" |
| 29 | PYTHONRDEPS_class-native = "" |
| 30 | |
| 31 | PACKAGECONFIG = "python update-alternatives" |
| 32 | PACKAGECONFIG[python] = ",,,${PYTHONRDEPS}" |
| 33 | PACKAGECONFIG[update-alternatives] = ",,," |
| 34 | |
| 35 | do_install() { |
| 36 | oe_runmake PREFIX=${prefix} DESTDIR=${D} install |
| 37 | if ! ${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'true', 'false', d)}; then |
| 38 | rm -f "${D}${bindir}/update-alternatives" |
| 39 | fi |
| 40 | |
| 41 | if ! ${@bb.utils.contains('PACKAGECONFIG', 'python', 'true', 'false', d)}; then |
| 42 | grep -lZ "/usr/bin/env.*python" ${D}${bindir}/* | xargs -0 rm |
| 43 | fi |
| 44 | } |
| 45 | |
| 46 | do_install_append_class-target() { |
| 47 | if [ -e "${D}${bindir}/update-alternatives" ]; then |
| 48 | sed -i ${D}${bindir}/update-alternatives -e 's,/usr/bin,${bindir},g; s,/usr/lib,${nonarch_libdir},g' |
| 49 | fi |
| 50 | } |
| 51 | |
| 52 | # These are empty and will pull python3-dev into images where it wouldn't |
| 53 | # have been otherwise, so don't generate them. |
| 54 | PACKAGES_remove = "${PN}-dev ${PN}-staticdev" |
| 55 | |
| 56 | PACKAGES =+ "update-alternatives-opkg" |
| 57 | FILES_update-alternatives-opkg = "${bindir}/update-alternatives" |
| 58 | RPROVIDES_update-alternatives-opkg = "update-alternatives update-alternatives-cworth" |
| 59 | RREPLACES_update-alternatives-opkg = "update-alternatives-cworth" |
| 60 | RCONFLICTS_update-alternatives-opkg = "update-alternatives-cworth" |
| 61 | |
| 62 | pkg_postrm_update-alternatives-opkg() { |
| 63 | rm -rf $D${nonarch_libdir}/opkg/alternatives |
| 64 | rmdir $D${nonarch_libdir}/opkg || true |
| 65 | } |
| 66 | |
| 67 | BBCLASSEXTEND = "native nativesdk" |
| 68 | |
| 69 | CLEANBROKEN = "1" |