Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | require qemu.inc |
| 2 | |
| 3 | inherit ptest |
| 4 | |
| 5 | RDEPENDS_${PN}-ptest = "bash make" |
| 6 | |
| 7 | LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \ |
| 8 | file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913" |
| 9 | |
| 10 | SRC_URI = "https://download.qemu.org/${BPN}-${PV}.tar.xz \ |
| 11 | file://powerpc_rom.bin \ |
| 12 | file://0001-sdl.c-allow-user-to-disable-pointer-grabs.patch \ |
| 13 | file://0002-qemu-Add-missing-wacom-HID-descriptor.patch \ |
| 14 | file://0003-Add-subpackage-ptest-which-runs-all-unit-test-cases-.patch \ |
| 15 | file://run-ptest \ |
| 16 | file://0004-qemu-Add-addition-environment-space-to-boot-loader-q.patch \ |
| 17 | file://0005-qemu-disable-Valgrind.patch \ |
| 18 | file://0006-qemu-Limit-paths-searched-during-user-mode-emulation.patch \ |
| 19 | file://0007-qemu-native-set-ld.bfd-fix-cflags-and-set-some-envir.patch \ |
| 20 | file://0008-chardev-connect-socket-to-a-spawned-command.patch \ |
| 21 | file://0009-apic-fixup-fallthrough-to-PIC.patch \ |
| 22 | file://0010-linux-user-Fix-webkitgtk-hangs-on-32-bit-x86-target.patch \ |
| 23 | file://0011-Revert-linux-user-fix-mmap-munmap-mprotect-mremap-sh.patch \ |
| 24 | file://CVE-2018-15746.patch \ |
| 25 | file://CVE-2018-17958.patch \ |
| 26 | file://CVE-2018-17962.patch \ |
| 27 | file://CVE-2018-17963.patch \ |
| 28 | " |
| 29 | UPSTREAM_CHECK_REGEX = "qemu-(?P<pver>\d+(\.\d+)+)\.tar" |
| 30 | |
| 31 | SRC_URI_append_class-native = " \ |
| 32 | file://0012-fix-libcap-header-issue-on-some-distro.patch \ |
| 33 | file://0013-cpus.c-Add-error-messages-when-qemi_cpu_kick_thread-.patch \ |
| 34 | " |
| 35 | |
| 36 | SRC_URI[md5sum] = "6a5c8df583406ea24ef25b239c3243e0" |
| 37 | SRC_URI[sha256sum] = "8d7af64fe8bd5ea5c3bdf17131a8b858491bcce1ee3839425a6d91fb821b5713" |
| 38 | |
| 39 | COMPATIBLE_HOST_mipsarchn32 = "null" |
| 40 | COMPATIBLE_HOST_mipsarchn64 = "null" |
| 41 | |
| 42 | do_install_append() { |
| 43 | # Prevent QA warnings about installed ${localstatedir}/run |
| 44 | if [ -d ${D}${localstatedir}/run ]; then rmdir ${D}${localstatedir}/run; fi |
| 45 | install -Dm 0755 ${WORKDIR}/powerpc_rom.bin ${D}${datadir}/qemu |
| 46 | } |
| 47 | |
| 48 | do_compile_ptest() { |
| 49 | make buildtest-TESTS |
| 50 | } |
| 51 | |
| 52 | do_install_ptest() { |
| 53 | cp -rL ${B}/tests ${D}${PTEST_PATH} |
| 54 | find ${D}${PTEST_PATH}/tests -type f -name "*.[Sshcod]" | xargs -i rm -rf {} |
| 55 | |
| 56 | cp ${S}/tests/Makefile.include ${D}${PTEST_PATH}/tests |
| 57 | # Don't check the file genreated by configure |
| 58 | sed -i -e '/wildcard config-host.mak/d' \ |
| 59 | -e '$ {/endif/d}' ${D}${PTEST_PATH}/tests/Makefile.include |
| 60 | } |