Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | DESCRIPTION = "Collection of Vulkan examples" |
| 2 | LICENSE = "MIT" |
| 3 | DEPENDS = "zlib" |
| 4 | |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=dcf473723faabf17baa9b5f2207599d0 \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 6 | file://examples/triangle/triangle.cpp;endline=12;md5=bccd1bf9cadd9e10086cf7872157e4fa" |
| 7 | |
| 8 | SRCREV_glm = "01f9ab5b6d21e5062ac0f6e0f205c7fa2ca9d769" |
| 9 | SRCREV_gli = "8e43030b3e12bb58a4663d85adc5c752f89099c0" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 10 | |
| 11 | SRC_URI = "git://github.com/SaschaWillems/Vulkan.git \ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 12 | git://github.com/g-truc/glm;destsuffix=git/external/glm;name=glm \ |
| 13 | git://github.com/g-truc/gli;destsuffix=git/external/gli;name=gli \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 14 | file://0001-Don-t-build-demos-with-questionably-licensed-data.patch \ |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 15 | " |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 16 | UPSTREAM_CHECK_COMMITS = "1" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 17 | SRCREV = "ae0b59c6e2e8630a2ae26f4a0b7a72cbe7547948" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 18 | UPSTREAM_CHECK_GITTAGREGEX = "These are not the releases you're looking for" |
| 19 | S = "${WORKDIR}/git" |
| 20 | |
| 21 | REQUIRED_DISTRO_FEATURES = 'vulkan' |
| 22 | |
| 23 | inherit cmake distro_features_check |
| 24 | DEPENDS = "vulkan assimp" |
| 25 | |
| 26 | do_install_append () { |
| 27 | # Remove assets that have uncertain licenses |
| 28 | rm ${D}${datadir}/vulkan-demos/models/armor/* \ |
| 29 | ${D}${datadir}/vulkan-demos/models/sibenik/* \ |
| 30 | ${D}${datadir}/vulkan-demos/models/vulkanscene* \ |
| 31 | ${D}${datadir}/vulkan-demos/models/plants.dae \ |
| 32 | ${D}${datadir}/vulkan-demos/textures/texturearray_plants* |
| 33 | |
| 34 | mv ${D}${bindir}/screenshot ${D}${bindir}/vulkan-screenshot |
| 35 | } |
| 36 | |
| 37 | EXTRA_OECMAKE = "-DRESOURCE_INSTALL_DIR=${datadir}/vulkan-demos" |
| 38 | |
| 39 | ANY_OF_DISTRO_FEATURES = "x11 wayland" |
| 40 | |
| 41 | # Can only pick one of [wayland,xcb] |
| 42 | PACKAGECONFIG = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', 'xcb' ,d)}" |
| 43 | PACKAGECONFIG[wayland] = "-DUSE_WAYLAND_WSI=ON, -DUSE_WAYLAND_WSI=OFF, wayland" |
| 44 | PACKAGECONFIG[xcb] = ",,libxcb" |