blob: 3e18fba74fc034b222d2788874b53434798a7a4d [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "XFS Filesystem Dump Utility"
2DESCRIPTION = "The xfsdump package contains xfsdump, xfsrestore and a \
3 number of other utilities for administering XFS filesystems.\
4 xfsdump examines files in a filesystem, determines which \
5 need to be backed up, and copies those files to a \
6 specified disk, tape or other storage medium."
7HOMEPAGE = "http://oss.sgi.com/projects/xfs"
8SECTION = "base"
9LICENSE = "GPLv2"
10LIC_FILES_CHKSUM = "file://doc/COPYING;md5=15c832894d10ddd00dfcf57bee490ecc"
11DEPENDS = "xfsprogs attr"
12
13SRC_URI = "https://www.kernel.org/pub/linux/utils/fs/xfs/xfsdump/${BP}.tar.xz \
14 file://remove-install-as-user.patch \
15 ${@bb.utils.contains('DISTRO_FEATURES','usrmerge','file://0001-xfsdump-support-usrmerge.patch','',d)} \
16 "
17SRC_URI[md5sum] = "086f7582875b14c17522867ffe3e202b"
18SRC_URI[sha256sum] = "55aeede6232ddce6c9e79e2af88d6f808534df1552eb2bfaf7fb85b92add6dd1"
19
20inherit autotools-brokensep
21
22PARALLEL_MAKE = ""
23PACKAGECONFIG ??= ""
24PACKAGECONFIG[gettext] = "--enable-gettext=yes,--enable-gettext=no,gettext"
25
26CFLAGS += "-D_FILE_OFFSET_BITS=64"
27
28EXTRA_OEMAKE += "'LIBTOOL=${HOST_SYS}-libtool' V=1"
29
30do_configure () {
31 export DEBUG="-DNDEBUG"
32 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.guess ${S}
33 install -m 0755 ${STAGING_DATADIR_NATIVE}/gnu-config/config.sub ${S}
34 oe_runconf
35}
36
37do_install () {
38 export DIST_ROOT=${D}
39 oe_runmake install
40 oe_runmake install-dev
41}