Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 1 | SUMMARY = "High Availability monitor built upon LVS, VRRP and service pollers" |
| 2 | DESCRIPTION = "Keepalived is a routing software written in C. The main goal \ |
| 3 | of this project is to provide simple and robust facilities for loadbalancing \ |
| 4 | and high-availability to Linux system and Linux based infrastructures. \ |
| 5 | Loadbalancing framework relies on well-known and widely used Linux Virtual \ |
| 6 | Server (IPVS) kernel module providing Layer4 loadbalancing \ |
| 7 | " |
| 8 | HOMEPAGE = "http://www.keepalived.org/" |
| 9 | |
| 10 | LICENSE = "GPLv2" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 12 | |
| 13 | SRC_URI = "http://www.keepalived.org/software/${BP}.tar.gz" |
| 14 | SRC_URI[md5sum] = "a5966e8433b60998709c4a922a407bac" |
| 15 | SRC_URI[sha256sum] = "9670fbc5eb3dc113828be8b702549dc68ec9578cf83287520d935be76fc8f193" |
| 16 | |
| 17 | DEPENDS = "libnfnetlink openssl" |
| 18 | |
| 19 | inherit autotools pkgconfig systemd |
| 20 | |
| 21 | PACKAGECONFIG ??= "libnl snmp \ |
| 22 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ |
| 23 | " |
| 24 | PACKAGECONFIG[libnl] = "--enable-libnl,--disable-libnl,libnl" |
| 25 | PACKAGECONFIG[snmp] = "--enable-snmp,--disable-snmp,net-snmp" |
| 26 | PACKAGECONFIG[systemd] = "--with-init=systemd --with-systemdsystemunitdir=${systemd_system_unitdir},--with-init=SYSV,systemd" |
| 27 | |
| 28 | EXTRA_OECONF = "--disable-libiptc" |
| 29 | EXTRA_OEMAKE = "initdir=${sysconfdir}/init.d" |
| 30 | |
| 31 | do_install_append() { |
| 32 | if [ -f ${D}${sysconfdir}/init.d/${BPN} ]; then |
| 33 | chmod 0755 ${D}${sysconfdir}/init.d/${BPN} |
| 34 | sed -i 's#rc.d/##' ${D}${sysconfdir}/init.d/${BPN} |
| 35 | fi |
| 36 | |
| 37 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then |
| 38 | install -D -m 0644 ${B}/${BPN}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service |
| 39 | fi |
| 40 | } |
| 41 | |
| 42 | FILES_${PN} += "${datadir}/snmp/mibs/KEEPALIVED-MIB.txt" |
| 43 | |
| 44 | SYSTEMD_SERVICE_${PN} = "keepalived.service" |
| 45 | SYSTEMD_AUTO_ENABLE ?= "disable" |