Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 1 | # Copyright (C) 2020 Khem Raj <raj.khem@gmail.com> |
| 2 | # Released under the MIT license (see COPYING.MIT for the terms) |
| 3 | |
| 4 | SUMMARY = " Kronosnet, often referred to as knet, is a network abstraction layer designed for High Availability use cases, where redundancy, security, fault tolerance and fast fail-over are the core requirements of your application." |
| 5 | HOMEPAGE = "https://kronosnet.org/" |
| 6 | LICENSE = "GPL-2.0+ & LGPL-2.1" |
| 7 | LIC_FILES_CHKSUM = "file://COPYING.applications;md5=751419260aa954499f7abaabaa882bbe \ |
| 8 | file://COPYING.libraries;md5=2d5025d4aa3495befef8f17206a5b0a1" |
| 9 | SECTION = "libs" |
| 10 | DEPENDS = "doxygen-native libqb-native libxml2-native bzip2 libqb libxml2 libnl lksctp-tools lz4 lzo openssl nss xz zlib zstd" |
| 11 | |
| 12 | SRCREV = "0ba5985c3ddec8429b989f0e7bd3324f53e0a9b0" |
| 13 | SRC_URI = "git://github.com/kronosnet/kronosnet;protocol=https;branch=stable1" |
| 14 | |
| 15 | inherit autotools |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | # libknet/transport_udp.c:326:48: error: comparison of integers of different signs: 'unsigned long' and 'int' [-Werror,-Wsign-compare] |
| 20 | # for (cmsg = CMSG_FIRSTHDR(&msg);cmsg; cmsg = CMSG_NXTHDR(&msg, cmsg)) { |
| 21 | # ^~~~~~~~~~~~~~~~~~~~~~~ |
| 22 | CFLAGS_append_toolchain-clang = " -Wno-sign-compare" |
| 23 | |