Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 1 | SUMMARY = "Memory Efficient Serialization Library" |
| 2 | HOMEPAGE = "https://github.com/google/flatbuffers" |
| 3 | SECTION = "console/tools" |
| 4 | LICENSE = "Apache-2.0" |
| 5 | |
| 6 | PACKAGE_BEFORE_PN = "${PN}-compiler" |
| 7 | |
| 8 | RDEPENDS_${PN}-compiler = "${PN}" |
| 9 | RDEPENDS_${PN}-dev += "${PN}-compiler" |
| 10 | |
| 11 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57" |
| 12 | |
| 13 | SRCREV = "6df40a2471737b27271bdd9b900ab5f3aec746c7" |
| 14 | |
| 15 | SRC_URI = "git://github.com/google/flatbuffers.git" |
| 16 | |
| 17 | # Make sure C++11 is used, required for example for GCC 4.9 |
| 18 | CXXFLAGS += "-std=c++11 -fPIC" |
| 19 | BUILD_CXXFLAGS += "-std=c++11 -fPIC" |
| 20 | |
| 21 | # BUILD_TYPE=Release is required, otherwise flatc is not installed |
| 22 | EXTRA_OECMAKE += "\ |
| 23 | -DCMAKE_BUILD_TYPE=Release \ |
| 24 | -DFLATBUFFERS_BUILD_TESTS=OFF \ |
| 25 | -DFLATBUFFERS_BUILD_SHAREDLIB=ON \ |
| 26 | " |
| 27 | |
| 28 | inherit cmake |
| 29 | |
| 30 | S = "${WORKDIR}/git" |
| 31 | |
| 32 | FILES_${PN}-compiler = "${bindir}" |
| 33 | |
| 34 | BBCLASSEXTEND = "native nativesdk" |