Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 1 | SUMMARY = "gd is a library used to create PNG, JPEG, or WBMP images" |
| 2 | DESCRIPTION = "The gd graphics library allows your code to quickly draw images \ |
| 3 | complete with lines, arcs, text, multiple colors, cut and paste from other \ |
| 4 | images, and flood fills, and to write out the result as a PNG or JPEG file. \ |
| 5 | This is particularly useful in Web applications, where PNG and JPEG are two \ |
| 6 | of the formats accepted for inline images by most browsers. Note that gd is not \ |
| 7 | a paint program." |
| 8 | HOMEPAGE = "http://libgd.github.io/" |
| 9 | |
| 10 | SECTION = "libs" |
| 11 | LICENSE = "GD" |
| 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=8e5bc8627b9494741c905d65238c66b7" |
| 13 | |
| 14 | DEPENDS = "freetype libpng jpeg zlib tiff" |
| 15 | |
| 16 | SRC_URI = "git://github.com/libgd/libgd.git;branch=master \ |
| 17 | " |
| 18 | |
| 19 | SRCREV = "b079fa06223c3ab862c8f0eea58a968727971988" |
| 20 | |
| 21 | S = "${WORKDIR}/git" |
| 22 | |
| 23 | inherit autotools binconfig gettext pkgconfig |
| 24 | |
| 25 | EXTRA_OECONF += " --disable-rpath \ |
| 26 | --with-jpeg=${STAGING_LIBDIR}/.. \ |
| 27 | --with-freetype=yes \ |
| 28 | --without-fontconfig \ |
| 29 | --without-webp \ |
| 30 | --without-xpm \ |
| 31 | --without-x \ |
| 32 | " |
| 33 | |
| 34 | EXTRA_OEMAKE = 'LDFLAGS="${LDFLAGS}"' |
| 35 | |
| 36 | DEBUG_OPTIMIZATION_append = " -Wno-error=maybe-uninitialized" |
| 37 | |
| 38 | do_install_append() { |
| 39 | # cleanup buildpaths from gdlib.pc |
| 40 | sed -i -e 's#${STAGING_DIR_HOST}##g' ${D}${libdir}/pkgconfig/gdlib.pc |
| 41 | } |
| 42 | |
| 43 | PACKAGES += "${PN}-tools" |
| 44 | |
| 45 | FILES_${PN} = "${libdir}/lib*${SOLIBS}" |
| 46 | FILES_${PN}-tools = "${bindir}/*" |
| 47 | |
| 48 | PROVIDES += "${PN}-tools" |
| 49 | RPROVIDES_${PN}-tools = "${PN}-tools" |
| 50 | RDEPENDS_${PN}-tools = "perl perl-module-strict" |
| 51 | |
| 52 | CVE_PRODUCT = "libgd" |