Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 1 | SUMMARY = "Multiplatform C library implementing the SSHv2 and SSHv1 protocol" |
| 2 | HOMEPAGE = "http://www.libssh.org" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "LGPLv2.1" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=dabb4958b830e5df11d2b0ed8ea255a0" |
| 6 | |
| 7 | DEPENDS = "zlib openssl libgcrypt" |
| 8 | |
| 9 | SRC_URI = "git://git.libssh.org/projects/libssh.git;branch=stable-0.8" |
| 10 | SRCREV = "04685a74df9ce1db1bc116a83a0da78b4f4fa1f8" |
| 11 | |
| 12 | S = "${WORKDIR}/git" |
| 13 | |
| 14 | inherit cmake |
| 15 | |
| 16 | PACKAGECONFIG ??="" |
| 17 | PACKAGECONFIG[gssapi] = "-DWITH_GSSAPI=1, -DWITH_GSSAPI=0, krb5, " |
| 18 | |
| 19 | ARM_INSTRUCTION_SET_armv5 = "arm" |
| 20 | |
| 21 | EXTRA_OECMAKE = " \ |
| 22 | -DWITH_GCRYPT=1 \ |
| 23 | -DWITH_PCAP=1 \ |
| 24 | -DWITH_SFTP=1 \ |
| 25 | -DWITH_ZLIB=1 \ |
| 26 | -DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')} \ |
| 27 | " |
| 28 | |
| 29 | do_configure_prepend () { |
| 30 | # Disable building of examples |
| 31 | sed -i -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' ${S}/CMakeLists.txt \ |
| 32 | || bbfatal "Failed to disable examples" |
| 33 | } |
| 34 | |
| 35 | TOOLCHAIN = "gcc" |