blob: 865adc5a1b7d1f4fba9c455e23a8c5b730f2dff8 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Extremely fast non-cryptographic hash algorithm"
2DESCRIPTION = "xxHash is an extremely fast non-cryptographic hash algorithm, \
3working at speeds close to RAM limits."
4HOMEPAGE = "http://www.xxhash.com/"
5LICENSE = "BSD-2-Clause & GPL-2.0"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=01a7eba4212ef1e882777a38585e7a9b"
7
8SRC_URI = "git://github.com/Cyan4973/xxHash.git"
9UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
10
11SRCREV = "d408e9b0606d07b1ddc5452ffc0ec8512211b174"
12
13S = "${WORKDIR}/git"
14
15do_compile () {
16 oe_runmake all
17}
18
19do_install () {
20 oe_runmake DESTDIR=${D} install
21}