Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 1 | SUMMARY = "matplotlib: plotting with Python" |
| 2 | DESCRIPTION = "\ |
| 3 | Matplotlib is a Python 2D plotting library which produces \ |
| 4 | publication-quality figures in a variety of hardcopy formats \ |
| 5 | and interactive environments across platforms." |
| 6 | HOMEPAGE = "https://github.com/matplotlib/matplotlib" |
| 7 | SECTION = "devel/python" |
| 8 | LICENSE = "PSF" |
| 9 | LIC_FILES_CHKSUM = "\ |
| 10 | file://setup.py;beginline=250;endline=250;md5=2a114620e4e6843aa7568d5902501753 \ |
| 11 | file://LICENSE/LICENSE;md5=afec61498aa5f0c45936687da9a53d74 \ |
| 12 | " |
| 13 | DEPENDS = "\ |
| 14 | freetype \ |
| 15 | libpng \ |
| 16 | python3-numpy-native \ |
| 17 | python3-dateutil-native \ |
| 18 | python3-pytz-native \ |
| 19 | " |
| 20 | |
| 21 | SRC_URI[md5sum] = "6c018a644a88120886cc7211f7c826f0" |
| 22 | SRC_URI[sha256sum] = "ffe2f9cdcea1086fc414e82f42271ecf1976700b8edd16ca9d376189c6d93aee" |
| 23 | |
| 24 | inherit pypi setuptools3 pkgconfig |
| 25 | |
| 26 | RDEPENDS_${PN} = "\ |
| 27 | freetype \ |
| 28 | libpng \ |
| 29 | python3-numpy \ |
| 30 | python3-pyparsing \ |
| 31 | python3-cycler \ |
| 32 | python3-dateutil \ |
| 33 | python3-kiwisolver \ |
| 34 | python3-pytz \ |
| 35 | " |
| 36 | |
| 37 | BBCLASSEXTEND = "native" |