Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 1 | SUMMARY = "MessagePack (de)serializer" |
| 2 | LICENSE = "Apache-2.0" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=cd9523181d9d4fbf7ffca52eaa2a5751" |
| 4 | |
| 5 | PYPI_PACKAGE = "msgpack" |
| 6 | inherit pypi setuptools3 ptest |
| 7 | |
| 8 | SRC_URI[md5sum] = "ba46fdee995565f40e332bd7eea882f1" |
| 9 | SRC_URI[sha256sum] = "ea3c2f859346fcd55fc46e96885301d9c2f7a36d453f5d8f2967840efa1e1830" |
| 10 | |
| 11 | RDEPENDS_${PN}_class-target += "\ |
| 12 | ${PYTHON_PN}-io \ |
| 13 | " |
| 14 | |
| 15 | BBCLASSEXTEND = "native nativesdk" |
| 16 | |
| 17 | SRC_URI += " \ |
| 18 | file://run-ptest \ |
| 19 | " |
| 20 | |
| 21 | RDEPENDS_${PN}-ptest += " \ |
| 22 | ${PYTHON_PN}-pytest \ |
| 23 | " |
| 24 | |
| 25 | do_install_ptest() { |
| 26 | install -d ${D}${PTEST_PATH}/test |
| 27 | cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/ |
| 28 | } |