blob: 6d7e7a0dcd75f0144520e84534297b65fa710d55 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "MessagePack (de)serializer"
2LICENSE = "Apache-2.0"
3LIC_FILES_CHKSUM = "file://COPYING;md5=cd9523181d9d4fbf7ffca52eaa2a5751"
4
5PYPI_PACKAGE = "msgpack"
6inherit pypi setuptools3 ptest
7
8SRC_URI[md5sum] = "ba46fdee995565f40e332bd7eea882f1"
9SRC_URI[sha256sum] = "ea3c2f859346fcd55fc46e96885301d9c2f7a36d453f5d8f2967840efa1e1830"
10
11RDEPENDS_${PN}_class-target += "\
12 ${PYTHON_PN}-io \
13"
14
15BBCLASSEXTEND = "native nativesdk"
16
17SRC_URI += " \
18 file://run-ptest \
19"
20
21RDEPENDS_${PN}-ptest += " \
22 ${PYTHON_PN}-pytest \
23"
24
25do_install_ptest() {
26 install -d ${D}${PTEST_PATH}/test
27 cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/
28}