Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 1 | SUMMARY = "A pure Python netlink and Linux network configuration library" |
| 2 | LICENSE = "GPLv2 & Apache-2.0" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE.GPL.v2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 4 | file://LICENSE.Apache.v2;md5=34281e312165f843a2b7d1f114fe65ce" |
| 5 | |
| 6 | SRC_URI[md5sum] = "7005db01604663fc2ecc089925980e05" |
| 7 | SRC_URI[sha256sum] = "05e959f1a89d715158b91fe83b67946a4441e5e098cc225f4df78a3765ac4af2" |
| 8 | |
| 9 | inherit setuptools3 pypi ptest |
| 10 | |
| 11 | RDEPENDS_${PN} += " \ |
| 12 | ${PYTHON_PN}-ctypes \ |
| 13 | ${PYTHON_PN}-distutils \ |
| 14 | ${PYTHON_PN}-io \ |
| 15 | ${PYTHON_PN}-json \ |
| 16 | ${PYTHON_PN}-logging \ |
| 17 | ${PYTHON_PN}-multiprocessing \ |
| 18 | ${PYTHON_PN}-pickle \ |
| 19 | ${PYTHON_PN}-pkgutil \ |
| 20 | ${PYTHON_PN}-pprint \ |
| 21 | ${PYTHON_PN}-shell \ |
| 22 | ${PYTHON_PN}-unixadmin \ |
| 23 | " |
| 24 | |
| 25 | SRC_URI += " \ |
| 26 | file://run-ptest \ |
| 27 | " |
| 28 | |
| 29 | RDEPENDS_${PN}-ptest += " \ |
| 30 | ${PYTHON_PN}-pytest \ |
| 31 | ${PYTHON_PN}-fcntl \ |
| 32 | " |
| 33 | |
| 34 | do_install_ptest() { |
| 35 | install -d ${D}${PTEST_PATH}/tests |
| 36 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 37 | } |