Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 1 | SUMMARY = "A TOML-0.4.0 parser/writer for Python" |
| 2 | HOMEPAGE = "https://pypi.python.org/pypi/pytoml/" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=cfff423699bdaef24331933ac4f56078" |
| 6 | |
| 7 | SRC_URI[md5sum] = "e59dd36a559dd2a876e4c149c69e947b" |
| 8 | SRC_URI[sha256sum] = "8eecf7c8d0adcff3b375b09fe403407aa9b645c499e5ab8cac670ac4a35f61e7" |
| 9 | |
| 10 | inherit pypi setuptools3 ptest |
| 11 | |
| 12 | BBCLASSEXTEND = "native nativesdk" |
| 13 | |
| 14 | SRC_URI += " \ |
| 15 | file://run-ptest \ |
| 16 | " |
| 17 | |
| 18 | RDEPENDS_${PN}-ptest += " \ |
| 19 | ${PYTHON_PN}-pytest \ |
| 20 | " |
| 21 | |
| 22 | do_install_ptest() { |
| 23 | install -d ${D}${PTEST_PATH}/test |
| 24 | cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/ |
| 25 | } |