blob: f39847ffa74c92f19a253b635ac7525c8b89e821 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "A libudev binding"
2LICENSE = "LGPLv2.1+"
3LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343"
4
5SRC_URI[md5sum] = "cf4d9db7d772622144ca1be6b5d9353b"
6SRC_URI[sha256sum] = "094b7a100150114748aaa3b70663485dd360457a709bfaaafe5a977371033f2b"
7
Brad Bishopd7bf8c12018-02-25 22:55:05 -05008inherit pypi setuptools3
Andrew Geissler82c905d2020-04-13 13:39:40 -05009
10do_configure_prepend() {
11 sed -i "/import pyudev/d" ${S}/setup.py
12 sed -i "s/str(pyudev.__version__)/'${PV}'/g" ${S}/setup.py
13}
14
15RDEPENDS_${PN} = "\
16 ${PYTHON_PN}-ctypes \
17 ${PYTHON_PN}-misc \
18 ${PYTHON_PN}-six \
19 ${PYTHON_PN}-threading \
20 libudev \
21"