Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 1 | SUMMARY = "Python bindings for GStreamer 1.0" |
| 2 | HOMEPAGE = "http://cgit.freedesktop.org/gstreamer/gst-python/" |
| 3 | SECTION = "multimedia" |
| 4 | |
| 5 | LICENSE = "LGPLv2.1" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=c34deae4e395ca07e725ab0076a5f740" |
| 7 | |
| 8 | SRC_URI = "https://gstreamer.freedesktop.org/src/${PNREAL}/${PNREAL}-${PV}.tar.xz \ |
| 9 | file://0001-meson.build-fix-builds-with-python-3.8.patch \ |
| 10 | " |
| 11 | SRC_URI[md5sum] = "6ac709767334d8d0a71cb4e016f6abeb" |
| 12 | SRC_URI[sha256sum] = "208df3148d73d9f416d016564737585d8ea763d91201732d44b5fe688c6288a8" |
| 13 | |
| 14 | DEPENDS = "gstreamer1.0 python3-pygobject" |
| 15 | RDEPENDS_${PN} += "gstreamer1.0 python3-pygobject" |
| 16 | |
| 17 | PNREAL = "gst-python" |
| 18 | |
| 19 | S = "${WORKDIR}/${PNREAL}-${PV}" |
| 20 | |
| 21 | # gobject-introspection is mandatory and cannot be configured |
| 22 | REQUIRED_DISTRO_FEATURES = "gobject-introspection-data" |
| 23 | UNKNOWN_CONFIGURE_WHITELIST_append = " introspection" |
| 24 | |
| 25 | inherit meson pkgconfig distutils3-base upstream-version-is-even gobject-introspection features_check |
| 26 | |
| 27 | do_install_append() { |
| 28 | |
| 29 | # Note that this particular find line is taken from the Debian packaging for |
| 30 | # gst-python1.0. |
| 31 | find "${D}" \ |
| 32 | -name '*.pyc' -o \ |
| 33 | -name '*.pyo' -o \ |
| 34 | -name '*.la' -o \ |
| 35 | -name 'libgstpythonplugin*' \ |
| 36 | -delete |
| 37 | } |