Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | SUMMARY = "Key/value database library with extensible hashing" |
| 2 | HOMEPAGE = "http://www.gnu.org/software/gdbm/" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "GPLv3" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=241da1b9fe42e642cbb2c24d5e0c4d24" |
| 6 | |
| 7 | |
| 8 | SRC_URI = "${GNU_MIRROR}/gdbm/gdbm-${PV}.tar.gz \ |
| 9 | file://run-ptest \ |
| 10 | file://ptest.patch \ |
| 11 | " |
| 12 | |
| 13 | SRC_URI[md5sum] = "988dc82182121c7570e0cb8b4fcd5415" |
| 14 | SRC_URI[sha256sum] = "86e613527e5dba544e73208f42b78b7c022d4fa5a6d5498bf18c8d6f745b91dc" |
| 15 | |
| 16 | inherit autotools gettext texinfo lib_package ptest |
| 17 | |
| 18 | # Needed for dbm python module |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 19 | EXTRA_OECONF = "--enable-libgdbm-compat --without-readline" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 20 | |
| 21 | # Stop presence of dbm/nbdm on the host contaminating builds |
| 22 | CACHED_CONFIGUREVARS += "ac_cv_lib_ndbm_main=no ac_cv_lib_dbm_main=no" |
| 23 | |
| 24 | BBCLASSEXTEND = "native nativesdk" |
| 25 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame^] | 26 | CFLAGS += "-fcommon" |
| 27 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 28 | do_install_append () { |
| 29 | # Create a symlink to ndbm.h and gdbm.h in include/gdbm to let other packages to find |
| 30 | # these headers |
| 31 | install -d ${D}${includedir}/gdbm |
| 32 | ln -sf ../ndbm.h ${D}/${includedir}/gdbm/ndbm.h |
| 33 | ln -sf ../gdbm.h ${D}/${includedir}/gdbm/gdbm.h |
| 34 | } |
| 35 | |
| 36 | RDEPENDS_${PN}-ptest += "diffutils ${PN}-bin" |
| 37 | |
| 38 | do_compile_ptest() { |
| 39 | oe_runmake -C tests buildtests |
| 40 | } |
| 41 | |
| 42 | PACKAGES =+ "${PN}-compat \ |
| 43 | " |
| 44 | FILES_${PN}-compat = "${libdir}/libgdbm_compat${SOLIBS} \ |
| 45 | " |