blob: 550e126f7e743af0b91ce03930afc2b5dd5e032c [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Babel is a loop-avoiding distance-vector routing protocol"
2DESCRIPTION = "\
3Babel is a loop-avoiding distance-vector routing protocol for IPv6 and \
4IPv4 with fast convergence properties. It is based on the ideas in DSDV, AODV \
5and Cisco's EIGRP, but is designed to work well not only in wired networks \
6but also in wireless mesh networks, and has been extended with support \
7for overlay networks. Babel is in the process of becoming an IETF Standard. \
8"
9HOMEPAGE = "https://www.irif.fr/~jch/software/babel/"
10SECTION = "net"
11
12LICENSE = "MIT"
13LIC_FILES_CHKSUM = "file://LICENCE;md5=411a48ac3c2e9e0911b8dd9aed26f754"
14
15SRC_URI = "git://github.com/jech/babeld.git;protocol=git"
16SRCREV = "8627b6fcd4992f2e7992ecec97a4a4aa2d7ff099"
17
18S = "${WORKDIR}/git"
19
20do_compile () {
21 oe_runmake babeld
22}
23
24do_install () {
25 oe_runmake install.minimal PREFIX=${D}
26}
27