Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 1 | DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript" |
| 2 | HOMEPAGE = "http://nodejs.org" |
| 3 | LICENSE = "MIT & BSD & Artistic-2.0" |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=be980eb7ccafe287cb438076a65e888c" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 5 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 6 | DEPENDS = "openssl" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 7 | DEPENDS_append_class-target = " nodejs-native" |
| 8 | |
| 9 | inherit pkgconfig |
| 10 | |
| 11 | COMPATIBLE_MACHINE_armv4 = "(!.*armv4).*" |
| 12 | COMPATIBLE_MACHINE_armv5 = "(!.*armv5).*" |
| 13 | COMPATIBLE_MACHINE_mips64 = "(!.*mips64).*" |
| 14 | |
Brad Bishop | c1d3433 | 2019-09-09 14:56:00 -0400 | [diff] [blame] | 15 | COMPATIBLE_HOST_riscv64 = "null" |
| 16 | COMPATIBLE_HOST_riscv32 = "null" |
| 17 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 18 | SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz \ |
| 19 | file://0001-Disable-running-gyp-files-for-bundled-deps.patch \ |
| 20 | file://0003-Crypto-reduce-memory-usage-of-SignFinal.patch \ |
| 21 | file://0004-Make-compatibility-with-gcc-4.8.patch \ |
| 22 | file://0005-Link-atomic-library.patch \ |
| 23 | file://0006-Use-target-ldflags.patch \ |
| 24 | " |
| 25 | SRC_URI_append_class-target = " \ |
| 26 | file://0002-Using-native-torque.patch \ |
| 27 | " |
| 28 | |
Brad Bishop | c1d3433 | 2019-09-09 14:56:00 -0400 | [diff] [blame] | 29 | SRC_URI[md5sum] = "b41275a018e670947c1950b12f050a2f" |
| 30 | SRC_URI[sha256sum] = "7bf1123d7415964775b8f81fe6ec6dd5c3c08abb42bb71dfe4409dbeeba26bbd" |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 31 | |
| 32 | S = "${WORKDIR}/node-v${PV}" |
| 33 | |
| 34 | # v8 errors out if you have set CCACHE |
| 35 | CCACHE = "" |
| 36 | |
| 37 | def map_nodejs_arch(a, d): |
| 38 | import re |
| 39 | |
| 40 | if re.match('i.86$', a): return 'ia32' |
| 41 | elif re.match('x86_64$', a): return 'x64' |
| 42 | elif re.match('aarch64$', a): return 'arm64' |
| 43 | elif re.match('(powerpc64|ppc64le)$', a): return 'ppc64' |
| 44 | elif re.match('powerpc$', a): return 'ppc' |
| 45 | return a |
| 46 | |
| 47 | ARCHFLAGS_arm = "${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '--with-arm-float-abi=hard', '--with-arm-float-abi=softfp', d)} \ |
| 48 | ${@bb.utils.contains('TUNE_FEATURES', 'neon', '--with-arm-fpu=neon', \ |
| 49 | bb.utils.contains('TUNE_FEATURES', 'vfpv3d16', '--with-arm-fpu=vfpv3-d16', \ |
| 50 | bb.utils.contains('TUNE_FEATURES', 'vfpv3', '--with-arm-fpu=vfpv3', \ |
| 51 | '--with-arm-fpu=vfp', d), d), d)}" |
| 52 | GYP_DEFINES_append_mipsel = " mips_arch_variant='r1' " |
| 53 | ARCHFLAGS ?= "" |
| 54 | |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 55 | PACKAGECONFIG ??= "zlib icu" |
| 56 | PACKAGECONFIG[zlib] = "--shared-zlib,,zlib" |
| 57 | PACKAGECONFIG[icu] = "--with-intl=system-icu,--without-intl,icu" |
| 58 | |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 59 | # Node is way too cool to use proper autotools, so we install two wrappers to forcefully inject proper arch cflags to workaround gypi |
| 60 | do_configure () { |
| 61 | rm -rf ${S}/deps/openssl |
| 62 | export LD="${CXX}" |
| 63 | GYP_DEFINES="${GYP_DEFINES}" export GYP_DEFINES |
| 64 | # $TARGET_ARCH settings don't match --dest-cpu settings |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 65 | ./configure --prefix=${prefix} --without-snapshot --shared-openssl \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 66 | --dest-cpu="${@map_nodejs_arch(d.getVar('TARGET_ARCH'), d)}" \ |
| 67 | --dest-os=linux \ |
Brad Bishop | 26bdd44 | 2019-08-16 17:08:17 -0400 | [diff] [blame] | 68 | ${ARCHFLAGS} \ |
| 69 | ${PACKAGECONFIG_CONFARGS} |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 70 | } |
| 71 | |
| 72 | do_compile () { |
| 73 | export LD="${CXX}" |
| 74 | oe_runmake BUILDTYPE=Release |
| 75 | } |
| 76 | |
| 77 | do_install () { |
| 78 | oe_runmake install DESTDIR=${D} |
| 79 | } |
| 80 | |
| 81 | do_install_append_class-native() { |
| 82 | # use node from PATH instead of absolute path to sysroot |
| 83 | # node-v0.10.25/tools/install.py is using: |
| 84 | # shebang = os.path.join(node_prefix, 'bin/node') |
| 85 | # update_shebang(link_path, shebang) |
| 86 | # and node_prefix can be very long path to bindir in native sysroot and |
| 87 | # when it exceeds 128 character shebang limit it's stripped to incorrect path |
| 88 | # and npm fails to execute like in this case with 133 characters show in log.do_install: |
| 89 | # updating shebang of /home/jenkins/workspace/build-webos-nightly/device/qemux86/label/open-webos-builder/BUILD-qemux86/work/x86_64-linux/nodejs-native/0.10.15-r0/image/home/jenkins/workspace/build-webos-nightly/device/qemux86/label/open-webos-builder/BUILD-qemux86/sysroots/x86_64-linux/usr/bin/npm to /home/jenkins/workspace/build-webos-nightly/device/qemux86/label/open-webos-builder/BUILD-qemux86/sysroots/x86_64-linux/usr/bin/node |
| 90 | # /usr/bin/npm is symlink to /usr/lib/node_modules/npm/bin/npm-cli.js |
| 91 | # use sed on npm-cli.js because otherwise symlink is replaced with normal file and |
| 92 | # npm-cli.js continues to use old shebang |
| 93 | sed "1s^.*^#\!/usr/bin/env node^g" -i ${D}${exec_prefix}/lib/node_modules/npm/bin/npm-cli.js |
| 94 | |
| 95 | # Install the native torque to provide it within sysroot for the target compilation |
| 96 | install -d ${D}${bindir} |
| 97 | install -m 0755 ${S}/out/Release/torque ${D}${bindir}/torque |
| 98 | } |
| 99 | |
| 100 | do_install_append_class-target() { |
| 101 | sed "1s^.*^#\!${bindir}/env node^g" -i ${D}${exec_prefix}/lib/node_modules/npm/bin/npm-cli.js |
| 102 | } |
| 103 | |
| 104 | PACKAGES =+ "${PN}-npm" |
| 105 | FILES_${PN}-npm = "${exec_prefix}/lib/node_modules ${bindir}/npm ${bindir}/npx" |
Brad Bishop | 90ca747 | 2019-08-20 09:15:15 -0400 | [diff] [blame] | 106 | RDEPENDS_${PN}-npm = "bash python-core python-shell python-datetime python-subprocess python-textutils \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 107 | python-compiler python-misc python-multiprocessing" |
| 108 | |
| 109 | PACKAGES =+ "${PN}-systemtap" |
| 110 | FILES_${PN}-systemtap = "${datadir}/systemtap" |
| 111 | |
| 112 | |
| 113 | BBCLASSEXTEND = "native" |