blob: a978eebe47ccdd839b99cb8d62b77484b5835dee [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001DESCRIPTION = "nodeJS Evented I/O for V8 JavaScript"
2HOMEPAGE = "http://nodejs.org"
3LICENSE = "MIT & BSD & Artistic-2.0"
Brad Bishop26bdd442019-08-16 17:08:17 -04004LIC_FILES_CHKSUM = "file://LICENSE;md5=be980eb7ccafe287cb438076a65e888c"
Brad Bishop19323692019-04-05 15:28:33 -04005
Brad Bishop26bdd442019-08-16 17:08:17 -04006DEPENDS = "openssl"
Brad Bishop19323692019-04-05 15:28:33 -04007DEPENDS_append_class-target = " nodejs-native"
8
9inherit pkgconfig
10
11COMPATIBLE_MACHINE_armv4 = "(!.*armv4).*"
12COMPATIBLE_MACHINE_armv5 = "(!.*armv5).*"
13COMPATIBLE_MACHINE_mips64 = "(!.*mips64).*"
14
Brad Bishopc1d34332019-09-09 14:56:00 -040015COMPATIBLE_HOST_riscv64 = "null"
16COMPATIBLE_HOST_riscv32 = "null"
17
Brad Bishop19323692019-04-05 15:28:33 -040018SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.xz \
19 file://0001-Disable-running-gyp-files-for-bundled-deps.patch \
20 file://0003-Crypto-reduce-memory-usage-of-SignFinal.patch \
21 file://0004-Make-compatibility-with-gcc-4.8.patch \
22 file://0005-Link-atomic-library.patch \
23 file://0006-Use-target-ldflags.patch \
24 "
25SRC_URI_append_class-target = " \
26 file://0002-Using-native-torque.patch \
27 "
28
Brad Bishopc1d34332019-09-09 14:56:00 -040029SRC_URI[md5sum] = "b41275a018e670947c1950b12f050a2f"
30SRC_URI[sha256sum] = "7bf1123d7415964775b8f81fe6ec6dd5c3c08abb42bb71dfe4409dbeeba26bbd"
Brad Bishop19323692019-04-05 15:28:33 -040031
32S = "${WORKDIR}/node-v${PV}"
33
34# v8 errors out if you have set CCACHE
35CCACHE = ""
36
37def map_nodejs_arch(a, d):
38 import re
39
40 if re.match('i.86$', a): return 'ia32'
41 elif re.match('x86_64$', a): return 'x64'
42 elif re.match('aarch64$', a): return 'arm64'
43 elif re.match('(powerpc64|ppc64le)$', a): return 'ppc64'
44 elif re.match('powerpc$', a): return 'ppc'
45 return a
46
47ARCHFLAGS_arm = "${@bb.utils.contains('TUNE_FEATURES', 'callconvention-hard', '--with-arm-float-abi=hard', '--with-arm-float-abi=softfp', d)} \
48 ${@bb.utils.contains('TUNE_FEATURES', 'neon', '--with-arm-fpu=neon', \
49 bb.utils.contains('TUNE_FEATURES', 'vfpv3d16', '--with-arm-fpu=vfpv3-d16', \
50 bb.utils.contains('TUNE_FEATURES', 'vfpv3', '--with-arm-fpu=vfpv3', \
51 '--with-arm-fpu=vfp', d), d), d)}"
52GYP_DEFINES_append_mipsel = " mips_arch_variant='r1' "
53ARCHFLAGS ?= ""
54
Brad Bishop26bdd442019-08-16 17:08:17 -040055PACKAGECONFIG ??= "zlib icu"
56PACKAGECONFIG[zlib] = "--shared-zlib,,zlib"
57PACKAGECONFIG[icu] = "--with-intl=system-icu,--without-intl,icu"
58
Brad Bishop19323692019-04-05 15:28:33 -040059# Node is way too cool to use proper autotools, so we install two wrappers to forcefully inject proper arch cflags to workaround gypi
60do_configure () {
61 rm -rf ${S}/deps/openssl
62 export LD="${CXX}"
63 GYP_DEFINES="${GYP_DEFINES}" export GYP_DEFINES
64 # $TARGET_ARCH settings don't match --dest-cpu settings
Brad Bishop26bdd442019-08-16 17:08:17 -040065 ./configure --prefix=${prefix} --without-snapshot --shared-openssl \
Brad Bishop19323692019-04-05 15:28:33 -040066 --dest-cpu="${@map_nodejs_arch(d.getVar('TARGET_ARCH'), d)}" \
67 --dest-os=linux \
Brad Bishop26bdd442019-08-16 17:08:17 -040068 ${ARCHFLAGS} \
69 ${PACKAGECONFIG_CONFARGS}
Brad Bishop19323692019-04-05 15:28:33 -040070}
71
72do_compile () {
73 export LD="${CXX}"
74 oe_runmake BUILDTYPE=Release
75}
76
77do_install () {
78 oe_runmake install DESTDIR=${D}
79}
80
81do_install_append_class-native() {
82 # use node from PATH instead of absolute path to sysroot
83 # node-v0.10.25/tools/install.py is using:
84 # shebang = os.path.join(node_prefix, 'bin/node')
85 # update_shebang(link_path, shebang)
86 # and node_prefix can be very long path to bindir in native sysroot and
87 # when it exceeds 128 character shebang limit it's stripped to incorrect path
88 # and npm fails to execute like in this case with 133 characters show in log.do_install:
89 # updating shebang of /home/jenkins/workspace/build-webos-nightly/device/qemux86/label/open-webos-builder/BUILD-qemux86/work/x86_64-linux/nodejs-native/0.10.15-r0/image/home/jenkins/workspace/build-webos-nightly/device/qemux86/label/open-webos-builder/BUILD-qemux86/sysroots/x86_64-linux/usr/bin/npm to /home/jenkins/workspace/build-webos-nightly/device/qemux86/label/open-webos-builder/BUILD-qemux86/sysroots/x86_64-linux/usr/bin/node
90 # /usr/bin/npm is symlink to /usr/lib/node_modules/npm/bin/npm-cli.js
91 # use sed on npm-cli.js because otherwise symlink is replaced with normal file and
92 # npm-cli.js continues to use old shebang
93 sed "1s^.*^#\!/usr/bin/env node^g" -i ${D}${exec_prefix}/lib/node_modules/npm/bin/npm-cli.js
94
95 # Install the native torque to provide it within sysroot for the target compilation
96 install -d ${D}${bindir}
97 install -m 0755 ${S}/out/Release/torque ${D}${bindir}/torque
98}
99
100do_install_append_class-target() {
101 sed "1s^.*^#\!${bindir}/env node^g" -i ${D}${exec_prefix}/lib/node_modules/npm/bin/npm-cli.js
102}
103
104PACKAGES =+ "${PN}-npm"
105FILES_${PN}-npm = "${exec_prefix}/lib/node_modules ${bindir}/npm ${bindir}/npx"
Brad Bishop90ca7472019-08-20 09:15:15 -0400106RDEPENDS_${PN}-npm = "bash python-core python-shell python-datetime python-subprocess python-textutils \
Brad Bishop19323692019-04-05 15:28:33 -0400107 python-compiler python-misc python-multiprocessing"
108
109PACKAGES =+ "${PN}-systemtap"
110FILES_${PN}-systemtap = "${datadir}/systemtap"
111
112
113BBCLASSEXTEND = "native"