Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | SUMMARY = "Library for interfacing with IIO devices" |
| 2 | HOMEPAGE = "https://wiki.analog.com/resources/tools-software/linux-software/libiio" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "LGPLv2.1+" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING.txt;md5=7c13b3376cea0ce68d2d2da0a1b3a72c" |
| 6 | |
Brad Bishop | 6a62e0e | 2019-10-21 08:11:42 -0400 | [diff] [blame] | 7 | # v0.18 + a single commit fixing the build |
| 8 | SRCREV = "5090603d01779bb1717fb0c50953330e8770550f" |
| 9 | PV = "0.18+git${SRCPV}" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 10 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 11 | SRC_URI = "git://github.com/analogdevicesinc/libiio.git;protocol=https" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
Brad Bishop | 2d39a06 | 2019-10-28 08:33:36 -0400 | [diff] [blame] | 15 | inherit cmake python3native systemd distutils3-base |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 16 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 17 | DEPENDS = " \ |
| 18 | flex-native bison-native libaio \ |
| 19 | ${@bb.utils.contains('DISTRO_FEATURES', 'zeroconf', 'avahi', '', d)} \ |
| 20 | " |
| 21 | |
| 22 | EXTRA_OECMAKE = " \ |
| 23 | -DCMAKE_BUILD_TYPE=RelWithDebInfo \ |
| 24 | -DUDEV_RULES_INSTALL_DIR=${nonarch_base_libdir}/udev/rules.d \ |
| 25 | ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '-DWITH_SYSTEMD=ON -DSYSTEMD_UNIT_INSTALL_DIR=${systemd_system_unitdir}', '', d)} \ |
| 26 | " |
| 27 | |
Brad Bishop | 6a62e0e | 2019-10-21 08:11:42 -0400 | [diff] [blame] | 28 | PACKAGECONFIG ??= "USB_BACKEND NETWORK_BACKEND" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 29 | |
| 30 | PACKAGECONFIG[USB_BACKEND] = "-DWITH_USB_BACKEND=ON,-DWITH_USB_BACKEND=OFF,libusb1,libxml2" |
| 31 | PACKAGECONFIG[NETWORK_BACKEND] = "-DWITH_NETWORK_BACKEND=ON,-DWITH_NETWORK_BACKEND=OFF,libxml2" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 32 | |
Brad Bishop | 6a62e0e | 2019-10-21 08:11:42 -0400 | [diff] [blame] | 33 | PACKAGES =+ "${PN}-iiod ${PN}-tests ${PN}-${PYTHON_PN}" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 34 | |
Brad Bishop | 6a62e0e | 2019-10-21 08:11:42 -0400 | [diff] [blame] | 35 | RDEPENDS_${PN}-${PYTHON_PN} = "${PN} ${PYTHON_PN}-ctypes ${PYTHON_PN}-stringold" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 36 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 37 | FILES_${PN}-iiod = " \ |
| 38 | ${sbindir}/iiod \ |
| 39 | ${systemd_system_unitdir}/iiod.service \ |
| 40 | " |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 41 | FILES_${PN}-tests = "${bindir}" |
Brad Bishop | 6a62e0e | 2019-10-21 08:11:42 -0400 | [diff] [blame] | 42 | FILES_${PN}-${PYTHON_PN} = "${PYTHON_SITEPACKAGES_DIR}" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 43 | |
| 44 | SYSTEMD_PACKAGES = "${PN}-iiod" |
| 45 | SYSTEMD_SERVICE_${PN}-iiod = "iiod.service" |