Andrew Geissler | 82cfa66 | 2020-02-17 15:11:03 -0600 | [diff] [blame^] | 1 | SUMMARY = "OpenPOWER processor control services installation" |
| 2 | PR = "r1" |
| 3 | |
| 4 | LICENSE = "Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 6 | |
| 7 | inherit allarch |
| 8 | |
| 9 | RDEPENDS_${PN} += "op-proc-control" |
| 10 | RDEPENDS_${PN} += "phosphor-state-manager-obmc-targets" |
| 11 | |
| 12 | ALLOW_EMPTY_${PN} = "1" |
| 13 | |
| 14 | pkg_postinst_${PN}() { |
| 15 | mkdir -p $D$systemd_system_unitdir/obmc-host-stop@0.target.requires |
| 16 | mkdir -p $D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires |
| 17 | |
| 18 | LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.requires/op-stop-instructions@0.service" |
| 19 | TARGET="../op-stop-instructions@.service" |
| 20 | ln -s $TARGET $LINK |
| 21 | |
| 22 | LINK="$D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires/op-cfam-reset.service" |
| 23 | TARGET="../op-cfam-reset.service" |
| 24 | ln -s $TARGET $LINK |
| 25 | } |
| 26 | |
| 27 | pkg_prerm_${PN}() { |
| 28 | LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.requires/op-stop-instructions@0.service" |
| 29 | rm $LINK |
| 30 | LINK="$D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires/op-cfam-reset.service" |
| 31 | rm $LINK |
| 32 | } |