blob: 348727e44b4890d03c381e6890209d120a574ee3 [file] [log] [blame]
Brad Bishop2d39a062019-10-28 08:33:36 -04001SUMMARY = "Help browser for the GNOME desktop"
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = " \
4 file://COPYING;md5=6e1b9cb787e76d7e6946887a65caa754 \
5"
6
Brad Bishope42b3e32020-01-15 22:08:42 -05007inherit gnomebase itstool autotools-brokensep gsettings gettext gtk-doc features_check
8
9# for webkitgtk
10REQUIRED_DISTRO_FEATURES = "x11"
Brad Bishop2d39a062019-10-28 08:33:36 -040011
12SRC_URI[archive.md5sum] = "776e29bd16424c8712cbf340cfe6429b"
13SRC_URI[archive.sha256sum] = "e3d6527c5963d73206891b32f1f23363164be57de248555513bd0be77a7bd045"
14
15DEPENDS += " \
16 libxml2-native \
17 glib-2.0-native \
Brad Bishop2d39a062019-10-28 08:33:36 -040018 gtk+3 \
19 appstream-glib \
20 libxslt \
21 sqlite3 \
22 webkitgtk \
23 yelp-xsl \
24"
25
26do_configure_prepend() {
27 export ITSTOOL=${STAGING_BINDIR_NATIVE}/itstool
28}
29
30FILES_${PN} += " \
31 ${datadir}/metainfo \
32 ${datadir}/yelp-xsl \
33"
34
35RDEPENDS_${PN} += "yelp-xsl"