blob: 22a0498921bd0db3e56824eb420da4db4b8965af [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001DESCRIPTION = "The gSOAP toolkit provides a unique SOAP-to-C/C++ language binding \
2for the development of SOAP Web Services and clients."
3SECTION = "devel"
4LICENSE = "GPL-2.0-with-OpenSSL-exception"
5LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4f40a941379143186f9602242c3fb729 \
6 file://GPLv2_license.txt;md5=a33672dbe491b6517750a0389063508b"
7
8SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}2/${BPN}_${PV}.zip \
Brad Bishopd7bf8c12018-02-25 22:55:05 -05009 "
Brad Bishop996bc452019-12-02 13:05:15 -050010SRC_URI[md5sum] = "88031646018d60857f21246962d10011"
11SRC_URI[sha256sum] = "fe07aa152cd946ef8ebd3f87653f14c1d38efe7c6e6fce8c6f773c4814f79baf"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012
13inherit autotools
14
15BBCLASSEXTEND = "native"
16
17S = "${WORKDIR}/${BPN}-2.8"
18
19PARALLEL_MAKE = ""
20
21EXTRA_OEMAKE_class-target = "SOAP=${STAGING_BINDIR_NATIVE}/soapcpp2"
22
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080023DEPENDS = "openssl zlib flex bison bison-native"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050024DEPENDS_append_class-target = " gsoap-native"
25
26do_install_append() {
27 install -d ${D}${libdir}
28 for lib in libgsoapssl libgsoapssl++ libgsoap libgsoapck++ libgsoap++ libgsoapck
29 do
30 oe_libinstall -C gsoap $lib ${D}${libdir}
31 done
32}
33
34do_install_class-native() {
35 oe_runmake DESTDIR=${D} BINDIR=${D}${bindir} install
36}
37
38FILES_${PN} = "${bindir}/wsdl2h ${bindir}/soapcpp2"
39FILES_${PN} += "${datadir}"
40FILES_${PN}-staticdev = "${libdir}"
41FILES_${PN}-dev = "${includedir}"
42RRECOMMENDS_${PN}-dev = "${PN}-staticdev"