blob: 9193a06ea8055f0822e3558fe8d8e3c037b30fe1 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Provides a way to load and enumerate PKCS#11 modules"
Brad Bishopf3f93bb2019-10-16 14:33:32 -04002LICENSE = "BSD-3-Clause"
Brad Bishop19323692019-04-05 15:28:33 -04003LIC_FILES_CHKSUM = "file://COPYING;md5=02933887f609807fbb57aa4237d14a50"
4
5inherit autotools gettext pkgconfig gtk-doc
6
7DEPENDS = "libtasn1 libffi"
8
Brad Bishopf3f93bb2019-10-16 14:33:32 -04009SRC_URI = "git://github.com/p11-glue/p11-kit"
10SRCREV = "b0ebe7555c291808db29377ba79cb8326301f0a6"
Brad Bishop19323692019-04-05 15:28:33 -040011S = "${WORKDIR}/git"
12
13AUTOTOOLS_AUXDIR = "${S}/build/litter"
14
15PACKAGECONFIG ??= ""
16PACKAGECONFIG[trust-paths] = "--with-trust-paths=/etc/ssl/certs/ca-certificates.crt,--without-trust-paths,,ca-certificates"
17
18# This recipe does not use the standard gtk-doc m4 macros, and so the ./configure flags
19# that control gtk-doc build are non-standard
20EXTRA_OECONF_prepend_class-target = "${@bb.utils.contains('GTKDOC_ENABLED', 'True', '--enable-doc --enable-doc-html --disable-doc-pdf', \
21 '--disable-doc', d)} "
22
23# When building native recipes, disable gtkdoc, as it is not necessary,
24# pulls in additional dependencies, and makes build times longer
25EXTRA_OECONF_prepend_class-native = "--disable-doc "
26EXTRA_OECONF_prepend_class-nativesdk = "--disable-doc "
27
28UNKNOWN_CONFIGURE_WHITELIST_append = " --enable-gtk-doc-html --disable-gtk-doc-pdf --enable-gtk-doc --disable-gtk-doc"
29
30# p11-kit relies on these two being copied from source tree
31# instead of being regenerated by gtkdoc-scan, but doesn't setup
32# dependencies correctly when there is a parallel build. Let's pre-copy
33# them instead.
34do_compile_prepend () {
35 cp ${S}/doc/manual/p11-kit-overrides.txt ${S}/doc/manual/p11-kit-sections.txt ${B}/doc/manual/
36}
37
38FILES_${PN} += " \
39 ${libdir}/p11-kit-proxy.so \
40 ${libdir}/pkcs11/*.so \
41 ${libdir}/pkcs11/*.la"
42
43# PN contains p11-kit-proxy.so, a symlink to a loadable module
44INSANE_SKIP_${PN} = "dev-so"