Andrew Geissler | 84ad7c5 | 2020-06-27 00:00:16 -0500 | [diff] [blame^] | 1 | SUMMARY = "Device Tree Compiler" |
| 2 | HOMEPAGE = "https://devicetree.org/" |
| 3 | DESCRIPTION = "The Device Tree Compiler is a tool used to manipulate the Open-Firmware-like device tree used by PowerPC kernels." |
| 4 | SECTION = "bootloader" |
| 5 | LICENSE = "GPLv2 | BSD" |
| 6 | DEPENDS = "flex-native bison-native swig-native" |
| 7 | |
| 8 | SRC_URI = "git://git.kernel.org/pub/scm/utils/dtc/dtc.git" |
| 9 | |
| 10 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)" |
| 11 | |
| 12 | LIC_FILES_CHKSUM = "file://libfdt.i;beginline=1;endline=6;md5=afda088c974174a29108c8d80b5dce90" |
| 13 | |
| 14 | SRCREV = "60e0db3d65a1218b0d5a29474e769f28a18e3ca6" |
| 15 | |
| 16 | S = "${WORKDIR}/git/pylibfdt" |
| 17 | |
| 18 | DEPENDS += "libyaml dtc" |
| 19 | |
| 20 | inherit distutils3 |
| 21 | |
| 22 | do_configure_prepend() { |
| 23 | (cd ${S}/../ ; make version_gen.h ) |
| 24 | } |
| 25 | |
| 26 | BBCLASSEXTEND = "native nativesdk" |
| 27 | |