Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 1 | SUMMARY = "System load testing utility" |
| 2 | DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \ |
| 3 | imposes a configurable amount of CPU, memory, I/O, and disk stress on the system." |
| 4 | HOMEPAGE = "https://kernel.ubuntu.com/~cking/stress-ng/" |
| 5 | LICENSE = "GPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 7 | |
| 8 | SRC_URI = "https://kernel.ubuntu.com/~cking/tarballs/${BPN}/${BP}.tar.xz \ |
| 9 | file://0001-Do-not-preserve-ownership-when-installing-example-jo.patch \ |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 10 | " |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 11 | SRC_URI[md5sum] = "e02acd0bc00d3c6a81412537393c2436" |
| 12 | SRC_URI[sha256sum] = "4addeaabcfcb709581cbc4c61182317b8d91bcf31f529bfa899d170facfd75ce" |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 13 | |
| 14 | DEPENDS = "coreutils-native" |
| 15 | |
Brad Bishop | c68388fc | 2019-08-26 01:33:31 -0400 | [diff] [blame] | 16 | PROVIDES = "stress" |
| 17 | RPROVIDES_${PN} = "stress" |
| 18 | RREPLACES_${PN} = "stress" |
| 19 | RCONFLICTS_${PN} = "stress" |
| 20 | |
Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame] | 21 | inherit bash-completion |
| 22 | |
| 23 | do_install() { |
| 24 | oe_runmake DESTDIR=${D} install |
| 25 | } |