Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | require libpcap.inc |
| 2 | |
| 3 | SRC_URI += "file://aclocal.patch \ |
| 4 | file://libpcap-pkgconfig-support.patch \ |
| 5 | " |
| 6 | SRC_URI[md5sum] = "b2e13142bbaba857ab1c6894aedaf547" |
| 7 | SRC_URI[sha256sum] = "7ad3112187e88328b85e46dce7a9b949632af18ee74d97ffc3f2b41fe7f448b0" |
| 8 | |
| 9 | # |
| 10 | # make install doesn't cover the shared lib |
| 11 | # make install-shared is just broken (no symlinks) |
| 12 | # |
| 13 | |
| 14 | do_configure_prepend () { |
| 15 | #remove hardcoded references to /usr/include |
| 16 | sed 's|\([ "^'\''I]\+\)/usr/include/|\1${STAGING_INCDIR}/|g' -i ${S}/configure.in |
| 17 | } |
| 18 | |
| 19 | do_install_prepend () { |
| 20 | install -d ${D}${libdir} |
| 21 | install -d ${D}${bindir} |
| 22 | oe_runmake install-shared DESTDIR=${D} |
| 23 | oe_libinstall -a -so libpcap ${D}${libdir} |
| 24 | sed "s|@VERSION@|${PV}|" -i ${B}/libpcap.pc |
| 25 | install -D -m 0644 libpcap.pc ${D}${libdir}/pkgconfig/libpcap.pc |
| 26 | } |