Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | SUMMARY = "Delayed job execution and batch processing" |
| 2 | DESCRIPTION = "At allows for commands to be run at a particular time. Batch will execute commands when \ |
| 3 | the system load levels drop to a particular level." |
| 4 | SECTION = "base" |
| 5 | LICENSE = "GPLv2+" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4" |
| 7 | DEPENDS = "flex flex-native \ |
| 8 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" |
| 9 | |
| 10 | RDEPENDS_${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_DEPS}', '', d)} \ |
| 11 | " |
| 12 | |
| 13 | PAM_DEPS = "libpam libpam-runtime pam-plugin-env pam-plugin-limits" |
| 14 | |
| 15 | RCONFLICTS_${PN} = "atd" |
| 16 | RREPLACES_${PN} = "atd" |
| 17 | |
| 18 | SRC_URI = "${DEBIAN_MIRROR}/main/a/at/at_${PV}.orig.tar.gz;subdir=${BP} \ |
| 19 | file://fix_parallel_build_error.patch \ |
| 20 | file://posixtm.c \ |
| 21 | file://posixtm.h \ |
| 22 | file://file_replacement_with_gplv2.patch \ |
| 23 | file://atd.init \ |
| 24 | file://atd.service \ |
| 25 | ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \ |
| 26 | file://makefile-fix-parallel.patch \ |
| 27 | file://0001-remove-glibc-assumption.patch \ |
| 28 | file://configure-fix-with-without-selinux.patch \ |
| 29 | " |
| 30 | |
| 31 | PAM_SRC_URI = "file://pam.conf.patch \ |
| 32 | file://configure-add-enable-pam.patch" |
| 33 | |
| 34 | SRC_URI[md5sum] = "f67a7aab557cd5b4a1311079a08acebe" |
| 35 | SRC_URI[sha256sum] = "dbd5c8cb8edd53ef467363c3af0391c08769f1dbbd4d5002c59a4cd4cac11d52" |
| 36 | |
| 37 | EXTRA_OECONF += "ac_cv_path_SENDMAIL=/bin/true \ |
| 38 | --with-daemon_username=root \ |
| 39 | --with-daemon_groupname=root \ |
| 40 | --with-jobdir=/var/spool/at/jobs \ |
| 41 | --with-atspool=/var/spool/at/spool \ |
| 42 | ac_cv_header_security_pam_appl_h=${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'yes', 'no', d)} " |
| 43 | |
| 44 | inherit autotools-brokensep systemd update-rc.d |
| 45 | |
| 46 | INITSCRIPT_NAME = "atd" |
| 47 | INITSCRIPT_PARAMS = "defaults" |
| 48 | |
| 49 | SYSTEMD_SERVICE_${PN} = "atd.service" |
| 50 | |
| 51 | copy_sources() { |
| 52 | cp -f ${WORKDIR}/posixtm.[ch] ${S} |
| 53 | } |
| 54 | do_patch[postfuncs] += "copy_sources" |
| 55 | |
| 56 | do_install () { |
| 57 | oe_runmake -e "IROOT=${D}" install |
| 58 | |
| 59 | install -d ${D}${sysconfdir}/init.d |
| 60 | install -m 0755 ${WORKDIR}/atd.init ${D}${sysconfdir}/init.d/atd |
| 61 | |
| 62 | # install systemd unit files |
| 63 | install -d ${D}${systemd_unitdir}/system |
| 64 | install -m 0644 ${WORKDIR}/atd.service ${D}${systemd_unitdir}/system |
| 65 | sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/atd.service |
| 66 | |
| 67 | if [ "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}" = "pam" ]; then |
| 68 | install -D -m 0644 ${WORKDIR}/${BP}/pam.conf ${D}${sysconfdir}/pam.d/atd |
| 69 | fi |
| 70 | } |