Patrick Williams | d8c66bc | 2016-06-20 12:57:21 -0500 | [diff] [blame] | 1 | SUMMARY = "Framework for layout and rendering of internationalized text" |
| 2 | DESCRIPTION = "Pango is a library for laying out and rendering of text, \ |
| 3 | with an emphasis on internationalization. Pango can be used anywhere \ |
| 4 | that text layout is needed, though most of the work on Pango so far has \ |
| 5 | been done in the context of the GTK+ widget toolkit. Pango forms the \ |
| 6 | core of text and font handling for GTK+-2.x." |
| 7 | HOMEPAGE = "http://www.pango.org/" |
| 8 | BUGTRACKER = "http://bugzilla.gnome.org" |
| 9 | SECTION = "libs" |
| 10 | LICENSE = "LGPLv2.0+" |
| 11 | |
| 12 | LIC_FILES_CHKSUM = "file://COPYING;md5=3bf50002aefd002f49e7bb854063f7e7" |
| 13 | |
| 14 | inherit gnomebase gtk-doc ptest-gnome upstream-version-is-even gobject-introspection |
| 15 | |
| 16 | SRC_URI += "file://run-ptest \ |
| 17 | file://0001-Drop-introspection-macros-from-acinclude.m4.patch \ |
| 18 | " |
| 19 | |
| 20 | SRC_URI[archive.md5sum] = "7fde35d4a127b55ce8bbcefe109bc80d" |
| 21 | SRC_URI[archive.sha256sum] = "1320569f6c6d75d6b66172b2d28e59c56ee864ee9df202b76799c4506a214eb7" |
| 22 | |
| 23 | DEPENDS = "glib-2.0 glib-2.0-native fontconfig freetype virtual/libiconv cairo harfbuzz" |
| 24 | |
| 25 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}" |
| 26 | PACKAGECONFIG[x11] = "--with-xft,--without-xft,virtual/libx11 libxft" |
| 27 | |
| 28 | EXTRA_AUTORECONF = "" |
| 29 | |
| 30 | EXTRA_OECONF = " \ |
| 31 | --disable-debug \ |
| 32 | " |
| 33 | |
| 34 | LEAD_SONAME = "libpango-1.0*" |
| 35 | LIBV = "1.8.0" |
| 36 | |
| 37 | # This binary needs to be compiled for the host architecture. This isn't pretty! |
| 38 | do_compile_prepend_class-target () { |
| 39 | if ${@base_contains('DISTRO_FEATURES', 'ptest', 'true', 'false', d)}; then |
| 40 | make CC="${BUILD_CC}" CFLAGS="" LDFLAGS="" AM_CPPFLAGS="$(pkg-config-native --cflags glib-2.0)" gen_all_unicode_LDADD="$(pkg-config-native --libs glib-2.0)" -C ${B}/tests gen-all-unicode |
| 41 | fi |
| 42 | } |
| 43 | |
| 44 | FILES_${PN} = "${bindir}/* ${libdir}/libpango*${SOLIBS}" |
| 45 | FILES_${PN}-dev += "${libdir}/pango/${LIBV}/modules/*.la" |
| 46 | |
| 47 | RDEPENDS_${PN}-ptest += "liberation-fonts cantarell-fonts" |
| 48 | |
| 49 | RPROVIDES_${PN} += "pango-modules pango-module-indic-lang \ |
| 50 | pango-module-basic-fc pango-module-arabic-lang" |
| 51 | |
| 52 | BBCLASSEXTEND = "native" |