blob: c57ab1323c0a8f906f36eefae5e9dc85ccf7ff1b [file] [log] [blame]
Thang Q. Nguyen90bb5e12021-12-30 11:06:27 +00001SUMMARY = "Ampere Computing LLC Host temperature event monitor application"
2PR = "r1"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
5
6inherit obmc-phosphor-systemd
7inherit allarch
8
9DEPENDS += "virtual/obmc-gpio-monitor"
10RDEPENDS:${PN} += "virtual/obmc-gpio-monitor"
11
12OBMC_HOST_MONITOR_INSTANCES = "S0_overtemp S1_overtemp S0_hightemp_start S0_hightemp_stop S1_hightemp_start S1_hightemp_stop"
13
14# Copies config file having arguments for monitoring host overtemp
15# via GPIO assertion
16SYSTEMD_ENVIRONMENT_FILE:${PN} += " \
17 obmc/gpio/S0_overtemp \
18 obmc/gpio/S0_hightemp_start \
19 obmc/gpio/S0_hightemp_stop \
20 obmc/gpio/S1_overtemp \
21 obmc/gpio/S1_hightemp_start \
22 obmc/gpio/S1_hightemp_stop \
23 "
24
25
26SYSTEMD_SERVICE:${PN} = "ampere_overtemp@.service ampere_hightemp_start@.service ampere_hightemp_stop@.service"
27
28GPIO_MONITOR_TMPL = "phosphor-gpio-monitor@.service"
29GPIO_MONITOR_TGTFMT = "phosphor-gpio-monitor@{0}.service"
30TGT = "multi-user.target"
31TEMPEVENT_MONITOR_FMT = "../${GPIO_MONITOR_TMPL}:${TGT}.requires/${GPIO_MONITOR_TGTFMT}"
32SYSTEMD_LINK:${PN} += "${@compose_list(d, 'TEMPEVENT_MONITOR_FMT', 'OBMC_HOST_MONITOR_INSTANCES', 'OBMC_HOST_INSTANCES')}"