Thang Q. Nguyen | 90bb5e1 | 2021-12-30 11:06:27 +0000 | [diff] [blame] | 1 | SUMMARY = "Ampere Computing LLC Host temperature event monitor application" |
| 2 | PR = "r1" |
| 3 | LICENSE = "Apache-2.0" |
| 4 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 5 | |
| 6 | inherit obmc-phosphor-systemd |
| 7 | inherit allarch |
| 8 | |
| 9 | DEPENDS += "virtual/obmc-gpio-monitor" |
| 10 | RDEPENDS:${PN} += "virtual/obmc-gpio-monitor" |
| 11 | |
| 12 | OBMC_HOST_MONITOR_INSTANCES = "S0_overtemp S1_overtemp S0_hightemp_start S0_hightemp_stop S1_hightemp_start S1_hightemp_stop" |
| 13 | |
| 14 | # Copies config file having arguments for monitoring host overtemp |
| 15 | # via GPIO assertion |
| 16 | SYSTEMD_ENVIRONMENT_FILE:${PN} += " \ |
| 17 | obmc/gpio/S0_overtemp \ |
| 18 | obmc/gpio/S0_hightemp_start \ |
| 19 | obmc/gpio/S0_hightemp_stop \ |
| 20 | obmc/gpio/S1_overtemp \ |
| 21 | obmc/gpio/S1_hightemp_start \ |
| 22 | obmc/gpio/S1_hightemp_stop \ |
| 23 | " |
| 24 | |
| 25 | |
| 26 | SYSTEMD_SERVICE:${PN} = "ampere_overtemp@.service ampere_hightemp_start@.service ampere_hightemp_stop@.service" |
| 27 | |
| 28 | GPIO_MONITOR_TMPL = "phosphor-gpio-monitor@.service" |
| 29 | GPIO_MONITOR_TGTFMT = "phosphor-gpio-monitor@{0}.service" |
| 30 | TGT = "multi-user.target" |
| 31 | TEMPEVENT_MONITOR_FMT = "../${GPIO_MONITOR_TMPL}:${TGT}.requires/${GPIO_MONITOR_TGTFMT}" |
| 32 | SYSTEMD_LINK:${PN} += "${@compose_list(d, 'TEMPEVENT_MONITOR_FMT', 'OBMC_HOST_MONITOR_INSTANCES', 'OBMC_HOST_INSTANCES')}" |