Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 1 | SUMMARY = "GNOME Online Accounts - Single sign-on framework for GNOME" |
| 2 | LICENSE = "LGPLv2+" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=34c88b124db5fb2762c1676be7dadd36" |
| 4 | |
| 5 | GNOMEBASEBUILDCLASS = "autotools" |
| 6 | |
| 7 | inherit gnomebase gsettings gobject-introspection gsettings gtk-doc vala gettext upstream-version-is-even features_check |
| 8 | |
| 9 | # for webkitgtk |
| 10 | REQUIRED_DISTRO_FEATURES = "x11" |
| 11 | |
| 12 | DEPENDS = "glib-2.0" |
| 13 | |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 14 | SRC_URI[archive.md5sum] = "44a37e1f8d4cac1dca0c41b57b49c2d0" |
| 15 | SRC_URI[archive.sha256sum] = "1c8f62990833ca41188dbb80c5e99d99b57a62608ca675bbcd37bc2244742f2e" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 16 | |
| 17 | # backend is required for gnome-control-center |
| 18 | PACKAGECONFIG = "backend other" |
| 19 | |
| 20 | PACKAGECONFIG[backend] = "--enable-backend,--disable-backend,gtk+3 webkitgtk libsoup-2.4 json-glib libsecret rest libxml2" |
| 21 | PACKAGECONFIG[krb5] = "--enable-kerberos, --disable-kerberos , krb5 gcr" |
| 22 | |
| 23 | # no extra dependencies! |
| 24 | PACKAGECONFIG[other] = " \ |
| 25 | --enable-facebook --enable-foursquare --enable-exchange --enable-flickr --enable-google --enable-imap-smtp --enable-owncloud --enable-windows-live,\ |
| 26 | --disable-facebook --disable-foursquare --disable-exchange --disable-flickr --disable-google --disable-imap-smtp --disable-owncloud --disable-windows-live, \ |
| 27 | " |
| 28 | |
| 29 | FILES_${PN} += " \ |
| 30 | ${datadir}/dbus-1 \ |
| 31 | ${libdir}/goa-1.0/web-extensions/*.so \ |
| 32 | " |
| 33 | |
| 34 | # looked into pkg-config file: it is not a bug - they mean it |
| 35 | FILES_${PN}-dev += "${libdir}/goa-1.0/include" |