blob: 600508097b4e4346936702a6659fb400f9dd9c5c [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001DESCRIPTION = "PDF transformation/inspection software"
2HOMEPAGE = "http://qpdf.sourceforge.net"
3LICENSE = "Artistic-2.0"
4SECTION = "libs"
5DEPENDS = "libpcre zlib libjpeg-turbo"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/qpdf/qpdf-${PV}.tar.gz"
8
9LIC_FILES_CHKSUM = "file://Artistic-2.0;md5=7806296b9fae874361e6fb10072b7ee3"
Andrew Geissler7f40b712020-05-15 14:09:53 -050010SRC_URI[md5sum] = "eb7fb7c6cd5d3036bf4f7a5e3f44d995"
11SRC_URI[sha256sum] = "5d2277c738188b7f4e3f01a6db7f2937ed6df54671f1fba834cd3d7ff865827b"
Brad Bishope42b3e32020-01-15 22:08:42 -050012
13inherit autotools-brokensep gettext
14
15# disable random file detection for cross-compile
16EXTRA_OECONF = "--without-random \
17 --disable-static \
18 --disable-check-autofiles \
19 "
20
21EXTRA_OEMAKE_class-target = "LIBTOOL=${HOST_SYS}-libtool"
22
Andrew Geissler7f40b712020-05-15 14:09:53 -050023LDFLAGS_append_mipsarch = " -latomic"
24
Brad Bishope42b3e32020-01-15 22:08:42 -050025S="${WORKDIR}/${BPN}-${PV}"
26
27# avoid Makefile returning error on 'make clean' before configure was run
28CLEANBROKEN = "1"
29
30DEBIAN_NOAUTONAME_libqpdf = "1"
31
32PACKAGES =+ "libqpdf"
33FILES_libqpdf = "${libdir}/libqpdf.so.*"
34
Andrew Geisslereafcbb82020-06-05 17:59:17 -050035RDEPENDS_${PN} = "libqpdf"