blob: 8b5b1dd1605876085d8c352a63f02faf24c77199 [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Async http client/server framework"
2DESCRIPTION = "Asynchronous HTTP client/server framework for asyncio and Python"
3HOMEPAGE = "https://github.com/aio-libs/aiohttp"
4LICENSE = "Apache-2.0"
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -05005LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=3bf3d48554bdca1ea7fdb48de378c2ca"
Andrew Geissler82c905d2020-04-13 13:39:40 -05006
Andrew Geisslerbbbd5f42020-10-30 15:42:48 -05007SRC_URI[md5sum] = "ed78633cc420b29d3b61c7d877dc0901"
8SRC_URI[sha256sum] = "04f9d70f6c4d089be5068d7df6281e638f6820d4f1b1ec3dc012b0b43fa997d2"
Andrew Geissler82c905d2020-04-13 13:39:40 -05009
10PYPI_PACKAGE = "aiohttp"
11inherit setuptools3 pypi
12RDEPENDS_${PN} = "\
13 ${PYTHON_PN}-async-timeout \
14 ${PYTHON_PN}-attrs \
15 ${PYTHON_PN}-chardet \
16 ${PYTHON_PN}-idna-ssl \
17 ${PYTHON_PN}-misc \
18 ${PYTHON_PN}-multidict \
19 ${PYTHON_PN}-typing \
20 ${PYTHON_PN}-yarl \
21"