Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "Python driver for MongoDB <http://www.mongodb.org>" |
| 2 | DESCRIPTION = "\ |
| 3 | The PyMongo distribution contains tools for interacting with MongoDB \ |
| 4 | database from Python. The bson package is an implementation of the BSON \ |
| 5 | format for Python. The pymongo package is a native Python driver for \ |
| 6 | MongoDB. The gridfs package is a gridfs implementation on top of pymongo." |
| 7 | HOMEPAGE = "http://github.com/mongodb/mongo-python-driver" |
| 8 | LICENSE = "Apache-2.0" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| 10 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 11 | SRC_URI[md5sum] = "5d166c8f9500c83314deadebb95b6fd5" |
| 12 | SRC_URI[sha256sum] = "076a7f2f7c251635cf6116ac8e45eefac77758ee5a77ab7bd2f63999e957613b" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 13 | |
| 14 | inherit pypi setuptools3 |
| 15 | |
| 16 | PACKAGES =+ "${PYTHON_PN}-bson" |
| 17 | |
| 18 | FILES_${PYTHON_PN}-bson = "${PYTHON_SITEPACKAGES_DIR}/bson/*" |
| 19 | |
| 20 | RDEPENDS_${PYTHON_PN}-bson += " \ |
| 21 | ${PYTHON_PN}-datetime \ |
| 22 | ${PYTHON_PN}-json \ |
| 23 | ${PYTHON_PN}-netclient \ |
| 24 | ${PYTHON_PN}-numbers \ |
| 25 | ${PYTHON_PN}-threading \ |
| 26 | " |
| 27 | |
| 28 | RDEPENDS_${PN} += " \ |
| 29 | ${PYTHON_PN}-bson \ |
| 30 | ${PYTHON_PN}-pprint \ |
| 31 | " |