Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | DESCRIPTION="Xfce4 Window Manager" |
| 2 | SECTION = "x11/wm" |
| 3 | LICENSE = "GPLv2" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=d791728a073bc009b4ffaf00b7599855" |
| 5 | DEPENDS = "virtual/libx11 libxfce4util libxfce4ui xfconf libwnck3 dbus-glib libxinerama exo-native" |
| 6 | |
| 7 | inherit xfce update-alternatives distro_features_check |
| 8 | |
| 9 | REQUIRED_DISTRO_FEATURES = "x11" |
| 10 | |
| 11 | SRC_URI[md5sum] = "1a78bcc2100c03f6fea0dbce0ca813cf" |
| 12 | SRC_URI[sha256sum] = "75ebc20d313cff4905e76fc320254c30461dbfa985461b8e75dca04770cedf12" |
| 13 | |
| 14 | PACKAGECONFIG ?= " \ |
| 15 | ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'epoxy', '', d)} \ |
| 16 | xpresent \ |
| 17 | startup-notification \ |
| 18 | " |
| 19 | |
| 20 | PACKAGECONFIG[epoxy] = "--enable-epoxy,--disable-epoxy,libepoxy" |
| 21 | PACKAGECONFIG[xpresent] = "--enable-xpresent,--disable-xpresent,libxpresent" |
| 22 | PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-startup-notification,startup-notification" |
| 23 | |
| 24 | python populate_packages_prepend () { |
| 25 | themedir = d.expand('${datadir}/themes') |
| 26 | do_split_packages(d, themedir, '^(.*)', 'xfwm4-theme-%s', 'XFWM4 theme %s', allow_dirs=True) |
| 27 | } |
| 28 | |
| 29 | PACKAGES_DYNAMIC += "^xfwm4-theme-.*" |
| 30 | |
| 31 | ALTERNATIVE_${PN} = "x-window-manager" |
| 32 | ALTERNATIVE_TARGET[x-window-manager] = "${bindir}/xfwm4" |
| 33 | ALTERNATIVE_PRIORITY[x-window-manager] = "30" |
| 34 | |
| 35 | RDEPENDS_${PN} = "xfwm4-theme-default" |
| 36 | FILES_${PN} += "${libdir}/xfce4/xfwm4/helper-dialog \ |
| 37 | ${datadir}/xfwm4/defaults \ |
| 38 | " |