Patrick Williams | d849ec7 | 2016-08-17 14:59:38 -0500 | [diff] [blame] | 1 | HOMEPAGE = "http://cheeseshop.python.org/pypi/simplejson" |
| 2 | SUMMARY = "Simple, fast, extensible JSON encoder/decoder for Python" |
| 3 | DESCRIPTION = "\ |
| 4 | JSON <http://json.org> encoder and decoder for Python 2.5+ \ |
| 5 | and Python 3.3+. It is pure Python code with no dependencies, \ |
| 6 | but includes an optional C extension for a serious speed boost \ |
| 7 | " |
| 8 | SECTION = "devel/python" |
| 9 | LICENSE = "MIT" |
| 10 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c6338d7abd321c0b50a2a547e441c52e" |
| 11 | PR = "r0" |
| 12 | |
| 13 | SRCNAME = "simplejson" |
| 14 | |
| 15 | SRC_URI = "https://pypi.python.org/packages/source/s/simplejson/${SRCNAME}-${PV}.tar.gz" |
| 16 | SRC_URI[md5sum] = "117346e5ee4ed4434ffe485f8e58f5ed" |
| 17 | SRC_URI[sha256sum] = "63d7f7b14a20f29f74325a69e6db45925eaf6e3a003eab46c0234fd050a8c93f" |
| 18 | |
| 19 | S = "${WORKDIR}/${SRCNAME}-${PV}" |
| 20 | |
| 21 | inherit setuptools |
| 22 | |
| 23 | RDEPENDS_${PN} = "\ |
| 24 | python-core \ |
| 25 | python-re \ |
| 26 | python-io \ |
| 27 | python-netserver \ |
| 28 | python-numbers \ |
| 29 | " |
| 30 | |
| 31 | |