blob: 39dfce6143d410f354eb2b4ec33175e28bf4f3da [file] [log] [blame]
Patrick Williamsd849ec72016-08-17 14:59:38 -05001HOMEPAGE = "http://cheeseshop.python.org/pypi/simplejson"
2SUMMARY = "Simple, fast, extensible JSON encoder/decoder for Python"
3DESCRIPTION = "\
4 JSON <http://json.org> encoder and decoder for Python 2.5+ \
5 and Python 3.3+. It is pure Python code with no dependencies, \
6 but includes an optional C extension for a serious speed boost \
7 "
8SECTION = "devel/python"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=c6338d7abd321c0b50a2a547e441c52e"
11PR = "r0"
12
13SRCNAME = "simplejson"
14
15SRC_URI = "https://pypi.python.org/packages/source/s/simplejson/${SRCNAME}-${PV}.tar.gz"
16SRC_URI[md5sum] = "117346e5ee4ed4434ffe485f8e58f5ed"
17SRC_URI[sha256sum] = "63d7f7b14a20f29f74325a69e6db45925eaf6e3a003eab46c0234fd050a8c93f"
18
19S = "${WORKDIR}/${SRCNAME}-${PV}"
20
21inherit setuptools
22
23RDEPENDS_${PN} = "\
24 python-core \
25 python-re \
26 python-io \
27 python-netserver \
28 python-numbers \
29"
30
31