Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 1 | require libva.inc |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 2 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=2e48940f94acb0af582e5ef03537800f" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 4 | SRC_URI[md5sum] = "aef13eb48e01a47d1416d97462a22a11" |
| 5 | SRC_URI[sha256sum] = "6c57eb642d828af2411aa38f55dc10111e8c98976dbab8fd62e48629401eaea5" |
| 6 | |
Andrew Geissler | 4b740dc | 2020-05-05 08:54:39 -0500 | [diff] [blame] | 7 | PACKAGECONFIG ??= " \ |
| 8 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'glx', '', d)} \ |
| 9 | ${@bb.utils.filter('DISTRO_FEATURES', 'x11 wayland', d)} \ |
| 10 | " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 11 | |
Andrew Geissler | 4b740dc | 2020-05-05 08:54:39 -0500 | [diff] [blame] | 12 | PACKAGECONFIG[x11] = "-Dwith_x11=yes,-Dwith_x11=no,virtual/libx11 libxext libxfixes" |
| 13 | PACKAGECONFIG[glx] = "-Dwith_glx=yes,-Dwith_glx=no,virtual/mesa" |
| 14 | |
| 15 | PACKAGECONFIG[wayland] = "-Dwith_wayland=yes,-Dwith_wayland=no,wayland-native wayland" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 16 | |
| 17 | PACKAGES =+ "${PN}-x11 ${PN}-glx ${PN}-wayland" |
| 18 | |
| 19 | RDEPENDS_${PN}-x11 =+ "${PN}" |
| 20 | RDEPENDS_${PN}-glx =+ "${PN}-x11" |
| 21 | |
| 22 | FILES_${PN}-x11 =+ "${libdir}/libva-x11*${SOLIBS}" |
| 23 | FILES_${PN}-glx =+ "${libdir}/libva-glx*${SOLIBS}" |
| 24 | FILES_${PN}-wayland =+ "${libdir}/libva-wayland*${SOLIBS}" |