Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "Python Imaging Library (Fork). Pillow is the friendly PIL fork by Alex \ |
| 2 | Clark and Contributors. PIL is the Python Imaging Library by Fredrik Lundh and \ |
| 3 | Contributors." |
| 4 | HOMEPAGE = "https://pillow.readthedocs.io" |
| 5 | LICENSE = "MIT" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=bc416d18f294943285560364be7cbec1" |
| 7 | |
| 8 | SRC_URI = "git://github.com/python-pillow/Pillow.git;branch=main;protocol=https \ |
| 9 | file://0001-support-cross-compiling.patch \ |
| 10 | file://0001-explicitly-set-compile-options.patch \ |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame^] | 11 | file://run-ptest \ |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 12 | " |
| 13 | SRCREV ?= "82541b6dec8452cb612067fcebba1c5a1a2bfdc8" |
| 14 | |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame^] | 15 | inherit setuptools3 ptest |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 16 | |
| 17 | PIP_INSTALL_PACKAGE = "Pillow" |
| 18 | PIP_INSTALL_DIST_PATH = "${S}/dist" |
| 19 | |
| 20 | DEPENDS += " \ |
| 21 | zlib \ |
| 22 | jpeg \ |
| 23 | tiff \ |
| 24 | freetype \ |
| 25 | lcms \ |
| 26 | openjpeg \ |
| 27 | " |
| 28 | |
| 29 | RDEPENDS:${PN} += " \ |
| 30 | ${PYTHON_PN}-misc \ |
| 31 | ${PYTHON_PN}-logging \ |
| 32 | ${PYTHON_PN}-numbers \ |
| 33 | " |
| 34 | |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame^] | 35 | RDEPENDS:${PN}-ptest += " \ |
| 36 | bash \ |
| 37 | ghostscript \ |
| 38 | jpeg-tools \ |
| 39 | libwebp \ |
| 40 | ${PYTHON_PN}-core \ |
| 41 | ${PYTHON_PN}-image \ |
| 42 | ${PYTHON_PN}-mmap \ |
| 43 | ${PYTHON_PN}-pytest \ |
| 44 | ${PYTHON_PN}-pytest-timeout \ |
| 45 | ${PYTHON_PN}-resource \ |
| 46 | ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'tk', '', d)} \ |
| 47 | " |
| 48 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 49 | CVE_PRODUCT = "pillow" |
| 50 | |
| 51 | S = "${WORKDIR}/git" |
| 52 | |
| 53 | RPROVIDES:${PN} += "python3-imaging" |
| 54 | |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame^] | 55 | do_install_ptest() { |
| 56 | install -d ${D}${PTEST_PATH}/Tests |
| 57 | cp -rf ${S}/Tests ${D}${PTEST_PATH}/ |
| 58 | } |
| 59 | |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 60 | BBCLASSEXTEND = "native" |
| 61 | |
| 62 | SRCREV = "a5bbab1c1e63b439de191ef2040173713b26d2da" |