Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 1 | SUMMARY = "Makes working with XML feel like you are working with JSON" |
| 2 | AUTHOR = "Martin Blech" |
| 3 | HOMEPAGE = "https://github.com/martinblech/xmltodict" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=01441d50dc74476db58a41ac10cb9fa2" |
| 6 | |
Patrick Williams | 2194f50 | 2022-10-16 14:26:09 -0500 | [diff] [blame] | 7 | SRC_URI[sha256sum] = "341595a488e3e01a85a9d8911d8912fd922ede5fecc4dce437eb4b6c8d037e56" |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 8 | |
| 9 | PYPI_PACKAGE = "xmltodict" |
| 10 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 11 | inherit pypi setuptools3 ptest |
| 12 | |
| 13 | SRC_URI += " \ |
| 14 | file://run-ptest \ |
| 15 | " |
| 16 | |
Patrick Williams | 2194f50 | 2022-10-16 14:26:09 -0500 | [diff] [blame] | 17 | RDEPENDS:${PN} += " \ |
| 18 | ${PYTHON_PN}-core \ |
| 19 | ${PYTHON_PN}-xml \ |
| 20 | ${PYTHON_PN}-io \ |
| 21 | " |
| 22 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 23 | RDEPENDS:${PN}-ptest += " \ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 24 | ${PYTHON_PN}-pytest \ |
| 25 | " |
| 26 | |
| 27 | do_install_ptest() { |
| 28 | install -d ${D}${PTEST_PATH}/tests |
| 29 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ |
| 30 | } |