Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "An implementation of JSON Schema validation for Python" |
| 2 | HOMEPAGE = "https://github.com/Julian/jsonschema" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=7a60a81c146ec25599a3e1dabb8610a8 \ |
| 5 | file://json/LICENSE;md5=9d4de43111d33570c8fe49b4cb0e01af" |
| 6 | |
| 7 | SRC_URI[sha256sum] = "0f864437ab8b6076ba6707453ef8f98a6a0d512a80e93f8abdb676f737ecb60d" |
| 8 | |
| 9 | inherit pypi python_hatchling |
| 10 | |
| 11 | PACKAGES =+ "${PN}-tests" |
| 12 | FILES:${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/jsonschema/tests" |
| 13 | |
| 14 | DEPENDS += "${PYTHON_PN}-hatch-fancy-pypi-readme-native ${PYTHON_PN}-hatch-vcs-native " |
| 15 | |
| 16 | PACKAGECONFIG ??= "format" |
| 17 | PACKAGECONFIG[format] = ",,,\ |
| 18 | ${PYTHON_PN}-idna \ |
| 19 | ${PYTHON_PN}-jsonpointer \ |
| 20 | ${PYTHON_PN}-webcolors \ |
| 21 | ${PYTHON_PN}-rfc3987 \ |
| 22 | ${PYTHON_PN}-rfc3339-validator \ |
| 23 | " |
| 24 | PACKAGECONFIG[nongpl] = ",,,\ |
| 25 | ${PYTHON_PN}-idna \ |
| 26 | ${PYTHON_PN}-jsonpointer \ |
| 27 | ${PYTHON_PN}-webcolors \ |
| 28 | ${PYTHON_PN}-rfc3986-validator \ |
| 29 | ${PYTHON_PN}-rfc3339-validator \ |
| 30 | " |
| 31 | |
| 32 | RDEPENDS:${PN} += " \ |
| 33 | ${PYTHON_PN}-attrs \ |
| 34 | ${PYTHON_PN}-core \ |
| 35 | ${PYTHON_PN}-datetime \ |
| 36 | ${PYTHON_PN}-importlib-metadata \ |
| 37 | ${PYTHON_PN}-io \ |
| 38 | ${PYTHON_PN}-json \ |
| 39 | ${PYTHON_PN}-netclient \ |
| 40 | ${PYTHON_PN}-numbers \ |
| 41 | ${PYTHON_PN}-pprint \ |
| 42 | ${PYTHON_PN}-pyrsistent \ |
| 43 | ${PYTHON_PN}-zipp \ |
| 44 | " |
| 45 | |
| 46 | RDEPENDS:${PN}-tests = "${PN}" |
| 47 | |
| 48 | BBCLASSEXTEND = "native nativesdk" |