Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "OpenGL / OpenGL ES Reference Compiler" |
| 2 | DESCRIPTION = "Glslang is the official reference compiler front end for the \ |
| 3 | OpenGL ES and OpenGL shading languages. It implements a strict interpretation \ |
| 4 | of the specifications for these languages. It is open and free for anyone to use, \ |
| 5 | either from a command line or programmatically." |
| 6 | SECTION = "graphics" |
| 7 | HOMEPAGE = "https://www.khronos.org/opengles/sdk/tools/Reference-Compiler" |
| 8 | LICENSE = "BSD-3-Clause & BSD-2-Clause & MIT & Apache-2.0 & GPL-3-with-bison-exception" |
| 9 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2a2b5acd7bc4844964cfda45fe807dc3" |
| 10 | |
Patrick Williams | 864cc43 | 2023-02-09 14:54:44 -0600 | [diff] [blame^] | 11 | SRCREV = "ca8d07d0bc1c6390b83915700439fa7719de6a2a" |
| 12 | SRC_URI = "git://github.com/KhronosGroup/glslang.git;protocol=https;branch=main \ |
| 13 | file://0001-generate-glslang-pkg-config.patch \ |
| 14 | " |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 15 | PE = "1" |
| 16 | UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)" |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | inherit cmake python3native |
| 20 | |
| 21 | EXTRA_OECMAKE = " \ |
| 22 | -DCMAKE_BUILD_TYPE=Release \ |
| 23 | -DBUILD_SHARED_LIBS=ON \ |
| 24 | -DENABLE_PCH=OFF \ |
| 25 | -DENABLE_CTEST=OFF \ |
| 26 | -DBUILD_EXTERNAL=OFF \ |
| 27 | " |
| 28 | |
| 29 | SOLIBSDEV = "glslang.so" |
| 30 | # all the other libraries are unversioned, so pack it on PN |
| 31 | FILES:${PN} += "${libdir}/*.so" |
| 32 | |
| 33 | BBCLASSEXTEND = "native nativesdk" |